aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ntp.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index cb9fdaa09f..ebc14ee819 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -120,7 +120,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
(define-public ntp
(package
(name "ntp")
- (version "4.2.8p17")
+ (version "4.2.8p18")
(source
(origin
(method url-fetch)
@@ -133,7 +133,7 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
(version-major+minor version)
"/ntp-" version ".tar.gz")))
(sha256
- (base32 "0rm8sf4qwcip49wgpgcp2dpwspsm0ad5xkkxy26mnv56wrrd4g8h"))
+ (base32 "1rb8yksqxjcsjvww9kwnw1242qzszwixh916jj254a8szgrwb16g"))
(modules '((guix build utils)))
(snippet
'(begin
:36 +0100'>2020-03-09tests: docker-system: Increase memory requirement....The system image would no longer fit in memory, starting from commit 8c7eb58453870f380a077c7cfd8dafa97bb8e13f. * gnu/tests/docker.scm (run-docker-system-test): Set 'memory-size' to 3500. Ludovic Courtès 2020-03-09tests: zabbix: Set 'PATH' before running the scripts....This is a followup to 8b9cad01e9619f53dc5a65892ca6a09ca5de3447. * gnu/tests/monitoring.scm (run-zabbix-server-test)[test]: Set 'PATH' in MARIONETTE. Ludovic Courtès 2020-03-05tests: install: Add %test-gui-installed-os-encrypted....* gnu/tests/install.scm (%test-gui-installed-os-encrypted): New variable, (guided-installation-test): set a swap-device only if there is no encryption. Mathieu Othacehe 2020-03-05tests: install: Add "gui-installed-os"....* gnu/installer/tests.scm: New file. * gnu/local.mk (INSTALLER_MODULES): Add it. * gnu/tests/install.scm (run-install): Add #:gui-test. Add (gnu installer tests) to the marionette imported modules. Honor GUI-TEST. Check whether SCRIPT is true. (%root-password, %syslog-conf): New variable. (operating-system-with-console-syslog, gui-test-program) (guided-installation-test): New procedures. (%extra-packages, installation-os-for-gui-tests) (%test-gui-installed-os): New variable. Ludovic Courtès 2020-03-05tests: 'run-basic-test' can enter a root password....* gnu/tests/base.scm (run-basic-test): Add #:root-password and honor it. Ludovic Courtès 2020-03-02gnu: Add system test for CUPS....* gnu/tests/cups.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Adjust accordingly. Marius Bakke 2020-02-22tests: Factorize LUKS passphrase....* gnu/tests/install.scm (%luks-passphrase): New variable. (%encrypted-root-installation-script): Use it. (enter-luks-passphrase): Use it. Ludovic Courtès