aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/web.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/web.scm b/gnu/packages/web.scm
index 52f11c5d5b..c3ef146750 100644
--- a/gnu/packages/web.scm
+++ b/gnu/packages/web.scm
@@ -3671,6 +3671,26 @@ for the variables, loops and branches declared in the template. This allows
you to separate design from the data.")
(license license:perl-license)))
+(define-public perl-html-treebuilder-xpath
+ (package
+ (name "perl-html-treebuilder-xpath")
+ (version "0.14")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/M/MI/MIROD/HTML-TreeBuilder-XPath-"
+ version ".tar.gz"))
+ (sha256
+ (base32 "1wx4i1scng20n405fp3a4vrwvvq9bvbmg977wnd5j2ja8jrbvsr5"))))
+ (build-system perl-build-system)
+ (propagated-inputs (list perl-html-tree perl-xml-xpathengine))
+ (home-page "https://metacpan.org/release/HTML-TreeBuilder-XPath")
+ (synopsis "XPath support for @code{HTML::TreeBuilder}")
+ (description "This module implements @code{HTML::TreeBuilder::XPath} for
+@code{HTML::TreeBuilder}, making it easy to parse documents using XPath.")
+ (license license:perl-license)))
+
(define-public perl-http-body
(package
(name "perl-http-body")
e to gnu/home/services/shells.scm. Replace (gnu home-services utils) with (gnu home services utils). * gnu/home-services/shepherd.scm: Move to gnu/home/services/shepherd.scm. * gnu/home-services/symlink-manager.scm: Rename to gnu/home/services/symlink-manager.scm. * gnu/home-services/utils.scm: Rename to gnu/home/services/utils.scm. * gnu/home-services/xdg.scm: Rename to gnu/home/services/xdg.scm. * guix/scripts/home/import.scm: Replace (gnu home-services bash) with (gnu home services bash). * gnu/home-services.scm: Update documentation string. * doc/he-config-bare-bones.scm: Apply new (gnu home-services ...) modules location. * gnu/local.mk (GNU_SYSTEM_MODULES): Same. Oleg Pykhalov 2021-09-09gnu: home: Add doc comment about the module....Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com> Andrew Tropin 2021-09-09home: Add home-environment....* gnu/home.scm (home-environment, home-environment?, this-home-environment) (home-environment-derivation, home-environment-user-services) (home-environment-essential-services, home-environment-services) (home-environment-location, home-environment-with-provenance): New variables. * gnu/local.mk (GNU_SYSTEM_MODULES): Add home.scm. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com> Andrew Tropin