aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm4
-rw-r--r--gnu/packages/xml.scm1
-rw-r--r--guix/search-paths.scm4
3 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 90bf7575ba..1d94e25436 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -600,9 +600,7 @@ requires only 10MB of RAM.")
(list libxslt))
(propagated-inputs
(list perl-class-xsaccessor perl-test-trap))
- (native-search-paths
- ;; xsltproc's search paths, to avoid propagating libxslt.
- (list $XML_CATALOG_FILES))
+ (native-search-paths %libxslt-search-paths)
(home-page "https://www.shlomifish.org/open-source/projects/docmake/")
(synopsis "Translate DocBook/XML documentation into other file formats")
(description
diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 3e7a14616f..7506b3d4e1 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -367,6 +367,7 @@ formulas and hyperlinks to multiple worksheets in an Excel 2007+ XLSX file.")
xz))
(native-inputs
(list pkg-config))
+ (native-search-paths %libxslt-search-paths)
(description
"Libxslt is an XSLT C library developed for the GNOME project. It is
based on libxml for XML parsing, tree manipulation and XPath support.")
diff --git a/guix/search-paths.scm b/guix/search-paths.scm
index d325e57989..a935684952 100644
--- a/guix/search-paths.scm
+++ b/guix/search-paths.scm
@@ -46,6 +46,7 @@
$XML_CATALOG_FILES
%gcc-search-paths
+ %libxslt-search-paths
search-path-specification->sexp
sexp->search-path-specification
@@ -179,6 +180,9 @@
(file-pattern "^catalog\\.xml$")
(file-type 'regular)))
+(define %libxslt-search-paths
+ (list $SGML_CATALOG_FILES $XML_CATALOG_FILES))
+
(define (search-path-specification->sexp spec)
"Return an sexp representing SPEC, a <search-path-specification>. The sexp
corresponds to the arguments expected by `set-path-environment-variable'."