aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ipfs.scm37
1 files changed, 37 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 34fe17127c..241441fd69 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -183,6 +183,43 @@ that are shared between @command{go-ipfs/commands} and its rewrite
objects.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-datastore
+ (package
+ (name "go-github-com-ipfs-go-datastore")
+ (version "0.6.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-datastore")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1xbhh3gm7bgd2d1p821w8gmbh87aix1g1ynhbl7gjaxxyhrsh68n"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-datastore"))
+ (native-inputs
+ (list go-gopkg-in-check-v1))
+ (propagated-inputs
+ (list go-github-com-google-uuid
+ go-github-com-ipfs-go-detect-race
+ go-github-com-ipfs-go-ipfs-delay
+ go-github-com-jbenet-goprocess
+ go-go-uber-org-multierr
+ go-golang-org-x-xerrors))
+ (home-page "https://github.com/ipfs/go-datastore")
+ (synopsis "Key-value datastore interfaces")
+ (description
+ "Datastore is a generic layer of abstraction for data store and database access.
+It is a simple API with the aim to enable application development in a
+datastore-agnostic way, allowing datastores to be swapped seamlessly without
+changing application code. Thus, one can leverage different datastores with
+different strengths without committing the application to one datastore
+throughout its lifetime.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-detect-race
(package
(name "go-github-com-ipfs-go-detect-race")
ate-desktop-service' procedure....Bruno Victal 2023-04-07services: desktop: Remove 'gnome-desktop-service' procedure....Bruno Victal 2023-03-21services: Add x11-socket-directory-service-type....Bruno Victal 2023-03-10services: xorg: Deprecate 'screen-locker-service' procedure....Bruno Victal 2023-02-26services: desktop: Set default value for geoclue-service-type....Bruno Victal 2023-03-03services: dbus: Deprecate 'dbus-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'bluetooth-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'geoclue-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'udisks-service' procedure....Bruno Victal 2023-03-03services: desktop: Deprecate 'accountsservice-service' procedure....Bruno Victal 2023-03-03services: elogind-configuration: Do not ignore 'handle-hibernate-key' by defa......Bruno Victal 2023-03-03services: desktop: Deprecate 'elogind-service' procedure....Bruno Victal 2023-02-28gnu: sugar-desktop-configuration: Allow specification of activities....Ricardo Wurmus 2023-02-28services: Add sugar-desktop-service-type....Ricardo Wurmus 2023-02-25services: gnome-desktop-service-type: Extend setuid-program-service-type....Maxim Cournoyer 2023-02-25services: desktop: Extract a new gnome-package procedure....Maxim Cournoyer 2023-02-25services: gnome-polkit-settings: Add spice-gtk....Maxim Cournoyer 2022-12-30services: enlightenment: Load ddcutil udev rules....Efraim Flashner 2022-12-26gnu: services: Fix bluetooth-service docstring....Ivan Vilata i Balaguer 2022-11-18services: Add Shepherd 'configuration' action to various services....Ludovic Courtès