aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/irc.scm19
1 files changed, 19 insertions, 0 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index d6b8cf4b4b..75f0ebe482 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -849,6 +849,25 @@ interface for those who are accustomed to the ircII way of doing things.")
"This package provides an IRC library for Python, based on asyncio.")
(license license:isc)))
+(define-public python-ircmatch
+ (package
+ (name "python-ircmatch")
+ (version "1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "ircmatch" version))
+ (sha256
+ (base32 "1bn92bnk958c097jhwkas24i4a07h905hifix7bg111npc48536l"))))
+ (build-system pyproject-build-system)
+ (native-inputs (list python-setuptools python-wheel))
+ (home-page "https://pypi.org/project/ircmatch/")
+ (synopsis "Library for matching IRC masks based on atheme")
+ (description "This is a python extension which provides string comparison
+and matching functions from Atheme. They are hand-optimized for high
+performance when matching IRC hostmasks.")
+ (license license:isc)))
+
(define-public python-irc-parser-tests
(package
(name "python-irc-parser-tests")
emlin.scm ("elf-dynamic-info-needed, executable"): Expect only libguile and libc among NEEDED. ("strip-runpath"): Pass '--enable-new-dtags' to get RUNPATH, not RPATH. Ting-Wei Lan 2018-08-25Merge branch 'staging' into core-updatesMarius Bakke 2018-08-21gremlin: 'elf-dynamic-info-needed' test is no longer skipped....* tests/gremlin.scm (%guile-executable): Use /proc/self/exe instead of (command-line). For a while now, the first element of (command-line) was "./build-aux/test-driver.scm"; consequently the test was always skipped. Ludovic Courtès 2018-05-07gremlin: Add 'strip-runpath'....* guix/build/gremlin.scm (strip-runpath): New procedure. * tests/gremlin.scm (c-compiler): New variable. ("strip-runpath"): New test. Ludovic Courtès