;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2020 Liliana Marie Prikler ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see . (define-module (gnu packages convmv) #:use-module (gnu packages) #:use-module (gnu packages perl) #:use-module (guix licenses) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu)) (define-public convmv (package (name "convmv") (version "2.05") (source (origin (method url-fetch) (uri (string-append "https://www.j3e.de/linux/convmv/convmv-" version ".tar.gz")) (sha256 (base32 "19hwv197p7c23f43vvav5bs19z9b72jzca2npkjsxgprwj5ardjk")))) (build-system gnu-build-system) (arguments `(#:test-target "test" #:make-flags `(,(string-append "PREFIX=" (assoc-ref %outputs "out"))) #:phases (modify-phases %standard-phases (delete 'bootstrap) (delete 'configure) (add-before 'check 'unpack-testsuite (lambda _ (invoke "tar" "xf" "testsuite.tar") (patch-shebang "suite/dotests.sh") (patch-shebang "suite/parsable_tester.pl") #t))))) (inputs (list perl)) (synopsis "Convert filenames between character sets") (description "convmv is a file renamer, that converts between different encodings, e.g. from ISO-8859-1 to UTF-8. It is particularly usefuls for files with names, that display incorrectly.") (license (list gpl2 gpl3)) (home-page "https://www.j3e.de/"))) 6f2a684e4300d058d1e0d'/>
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 528c07d9f1..3f5cdc404d 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1035,6 +1035,29 @@ increment versions.")
@end itemize")
(license license:bsd-3)))
+(define-public go-github-com-jbenet-go-temp-err-catcher
+ (package
+ (name "go-github-com-jbenet-go-temp-err-catcher")
+ (version "0.1.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jbenet/go-temp-err-catcher")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0n482jhh6jwq43jj21xkq8grqzx78hjh7f44p0q3n01zp1dsh97r"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/jbenet/go-temp-err-catcher"))
+ (home-page "https://github.com/jbenet/go-temp-err-catcher")
+ (synopsis "Error handling helper library")
+ (description "Package @code{temperrcatcher} provides a @code{TempErrCatcher}
+object, which implements simple error-retrying functionality.")
+ (license license:expat)))
+
(define-public go-github-com-jbenet-goprocess
(package
(name "go-github-com-jbenet-goprocess")