aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gl.scm10
-rw-r--r--gnu/packages/python-xyz.scm1
2 files changed, 8 insertions, 3 deletions
diff --git a/gnu/packages/gl.scm b/gnu/packages/gl.scm
index 1262d25137..c977c03949 100644
--- a/gnu/packages/gl.scm
+++ b/gnu/packages/gl.scm
@@ -348,6 +348,10 @@ also known as DXTn or DXTC) for Mesa.")
python-pyyaml
python-wrapper
(@ (gnu packages base) which))
+ (if (target-arm?)
+ ;; Needed for etnaviv.
+ (list python-pycparser)
+ '())
(if (%current-target-system)
(list cmake-minimal-cross
pkg-config-for-build
@@ -362,11 +366,11 @@ also known as DXTn or DXTC) for Mesa.")
#$@(cond
((target-aarch64?)
;; This includes more drivers than "auto": asahi, r300, r600
- '("-Dgallium-drivers=asahi,etnaviv,freedreno,kmsro,lima,\
-nouveau,panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
+ '("-Dgallium-drivers=asahi,etnaviv,freedreno,lima,nouveau,\
+panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((target-arm32?)
;; This includes more drivers than "auto": r300, r600
- '("-Dgallium-drivers=etnaviv,freedreno,kmsro,lima,nouveau,\
+ '("-Dgallium-drivers=etnaviv,freedreno,lima,nouveau,\
panfrost,r300,r600,svga,softpipe,llvmpipe,tegra,v3d,vc4,virgl,zink"))
((or (target-ppc64le?) (target-ppc32?) (target-riscv64?))
;; This include more drivers than "auto": svga
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 7ebe94716a..5083473c08 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10987,6 +10987,7 @@ data, and scientific formats.")
a multithreaded image-processing system with low memory needs.")
(license license:expat)))
+;; WARNING: This package is a dependency of mesa.
(define-public python-pycparser
(package
(name "python-pycparser")