aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/jupyter.scm12
1 files changed, 9 insertions, 3 deletions
diff --git a/gnu/packages/jupyter.scm b/gnu/packages/jupyter.scm
index 0e9ea14189..f86b59489a 100644
--- a/gnu/packages/jupyter.scm
+++ b/gnu/packages/jupyter.scm
@@ -742,14 +742,14 @@ and a default CommManager that can be used.")
(define-public python-nbclient
(package
(name "python-nbclient")
- (version "0.6.6")
+ (version "0.10.0")
(source
(origin
(method url-fetch)
(uri (pypi-uri "nbclient" version))
(sha256
(base32
- "09whkb8ll1nfdn4h3k0shncgkfak4lglmiwn8wdni6nrc5wnmxqd"))))
+ "02dvb9ffpd237apyj4fw97a9371kv99lzny49624j7jkp9yingsb"))))
(build-system pyproject-build-system)
;; Tests require tools from nbconvert, which would introduces a cycle.
(arguments '(#:tests? #false))
@@ -757,7 +757,13 @@ and a default CommManager that can be used.")
(list python-jupyter-client python-jupyter-core python-nbformat
python-traitlets))
(native-inputs
- (list python-setuptools python-wheel))
+ (list python-hatchling
+ python-flaky
+ python-pytest
+ python-pytest-asyncio
+ python-pytest-cov
+ python-testpath
+ python-xmltodict))
(home-page "https://jupyter.org")
(synopsis "Client library for executing notebooks")
(description