aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index af5055c392..dd37ae0d6c 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -27403,3 +27403,26 @@ percentages, citations, person tags, phone numbers, times, and zip codes.")
fashion. Safe means it does not rely on placeholders (which can cause errors
in same length matches).")
(license license:expat)))
+
+(define-public r-textshape
+ (package
+ (name "r-textshape")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "textshape" version))
+ (sha256
+ (base32
+ "02111kj3kka84mpx7s19bjna9cas8diw5fxz51v5ggz0ldswa5pa"))))
+ (properties `((upstream-name . "textshape")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-data-table" ,r-data-table)
+ ("r-slam" ,r-slam)
+ ("r-stringi" ,r-stringi)))
+ (home-page "http://github.com/trinker/textshape")
+ (synopsis "Tools for Reshaping Text")
+ (description
+ "Tools that can be used to reshape and restructure text data.")
+ (license license:gpl2)))
title='2017-05-08 20:08:23 +0200'>2017-05-08build: Add doc/guix.html to .gitignore....Clément Lassieur 2017-05-04build: Use Gnulib's 'git-version-gen'....Ludovic Courtès 2017-02-27.gitignore: Remove stale entries....Alex Kost 2017-02-10build: Add build-aux/ar-lib to .gitignore....Clément Lassieur 2017-01-13etc: Support indentation of whole files....Ludovic Courtès 2017-01-12etc: Add 'indent-package.el' script....Ludovic Courtès 2016-11-24Add system start-up files for "guix publish"....Hartmut Goebel 2016-11-16daemon: Add "builtin:download" derivation builder....Ludovic Courtès 2016-07-05build: Ignore texi2pdf temporary files....David Craven 2016-03-23doc: Add "lightweight desktop" OS config example....Ludovic Courtès