aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/games.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 055c9ba9b7..19bc495b00 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -7779,8 +7779,7 @@ quotation from a collection of quotes.")
(xonotic (string-append out "/share/xonotic"))
(source (assoc-ref %build-inputs "source"))
(unzip (search-input-file %build-inputs "/bin/unzip")))
- (copy-file source (string-append #$name "-" #$version ".zip"))
- (invoke unzip (string-append #$name "-" #$version ".zip"))
+ (invoke unzip source)
(chdir "Xonotic")
(install-file "key_0.d0pk" xonotic)
(copy-recursively "data"
ix/commit/build-aux/update-guix-package.scm?id=ccd9107ed9e8b918c6fb521cc69ac459fe4257ac'>update-guix-package: Use 'origin-hash'....* gnu/packages/package-management.scm (main): Use 'origin-hash' instead of 'origin-sha256'. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> Vincent Legoll 2018-12-07maint: update-guix-package: Really register GC roots....Previously we'd pass a relative file name to 'add-indirect-root', which the daemon would interpret as relative to "/". Consequently, checkouts were not protected from GC. * build-aux/update-guix-package.scm (main): Pass an absolute file name to 'add-indirect-root'. Ludovic Courtès