aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/audio.scm2
-rw-r--r--gnu/packages/games.scm2
-rw-r--r--gnu/packages/qt.scm12
-rw-r--r--gnu/packages/radio.scm4
-rw-r--r--gnu/packages/security-token.scm2
-rw-r--r--gnu/packages/sync.scm2
-rw-r--r--gnu/packages/video.scm2
7 files changed, 13 insertions, 13 deletions
diff --git a/gnu/packages/audio.scm b/gnu/packages/audio.scm
index 0bb607abfc..de3ed5b387 100644
--- a/gnu/packages/audio.scm
+++ b/gnu/packages/audio.scm
@@ -3235,7 +3235,7 @@ link REQUIRED)"))))))
qtdeclarative-5
qtsvg-5
qtwebchannel
- qtwebsockets))
+ qtwebsockets-5))
(propagated-inputs ;to get native-search-path
(list qtwebengine))
(home-page "https://github.com/supercollider/supercollider")
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 51dec55bd7..a851a6853a 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -996,7 +996,7 @@ want what you have.")
qtmultimedia-5
qtsvg-5
qttools
- qtwebsockets
+ qtwebsockets-5
xz
zlib))
(home-page "https://cockatrice.github.io")
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index d71b2991ad..d8838ec239 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -1202,7 +1202,7 @@ integrate QML code with JavaScript and C++.")
(description "The Qt Connectivity modules provides modules for interacting
with Bluetooth and NFC.")))
-(define-public qtwebsockets
+(define-public qtwebsockets-5
(package (inherit qtsvg-5)
(name "qtwebsockets")
(version "5.15.2")
@@ -1514,7 +1514,7 @@ and others.")))
(base32
"1h9y634phvvk557mhmf9z4lmxr41rl8x9mqy2lzp31mk8ffffzqj"))))
(native-inputs
- (list perl qtdeclarative-5 qtwebsockets))
+ (list perl qtdeclarative-5 qtwebsockets-5))
(inputs (list qtbase-5))
(synopsis "Web communication library for Qt")
(description "The Qt WebChannel module enables peer-to-peer communication
@@ -1542,7 +1542,7 @@ popular web engines, Qt WebKit 2 and Qt WebEngine.")))
#t))))))
(native-inputs '())
(inputs
- (list mesa qtbase-5 qtdeclarative-5 qtwebsockets zlib))
+ (list mesa qtbase-5 qtdeclarative-5 qtwebsockets-5 zlib))
(synopsis "QPA plugin for running an application via a browser using
streamed WebGL commands")
(description "Qt back end that uses WebGL for rendering. It allows Qt
@@ -2468,7 +2468,7 @@ module provides support functions to the automatically generated code.")
("qttools" ,qttools)
("qtwebchannel" ,qtwebchannel)
("qtwebkit" ,qtwebkit)
- ("qtwebsockets" ,qtwebsockets)
+ ("qtwebsockets-5" ,qtwebsockets-5)
("qtx11extras" ,qtx11extras)
("qtxmlpatterns" ,qtxmlpatterns)))
(arguments
@@ -3283,7 +3283,7 @@ color-related widgets.")
qtsvg-5
qtwebchannel
qtwebengine
- qtwebsockets
+ qtwebsockets-5
qtx11extras
qtxmlpatterns))
(propagated-inputs
@@ -3333,7 +3333,7 @@ color-related widgets.")
"qttools"
"qtwebchannel"
"qtwebengine"
- "qtwebsockets"
+ "qtwebsockets-5"
"qtx11extras"
"qtxmlpatterns"))))
(substitute* "cmake/Macros/PySideModules.cmake"
diff --git a/gnu/packages/radio.scm b/gnu/packages/radio.scm
index 989d5670f4..5f9767c896 100644
--- a/gnu/packages/radio.scm
+++ b/gnu/packages/radio.scm
@@ -1336,7 +1336,7 @@ weak-signal conditions.")
jtdx-hamlib
libusb
qtbase-5
- qtwebsockets
+ qtwebsockets-5
qtmultimedia-5
qtserialport))
(arguments
@@ -2165,7 +2165,7 @@ voice formats.")
qtquickcontrols2-5
qtserialport
qtspeech
- qtwebsockets
+ qtwebsockets-5
rtl-sdr
serialdv
soapysdr
diff --git a/gnu/packages/security-token.scm b/gnu/packages/security-token.scm
index 3c8d6d3321..5d95aebf14 100644
--- a/gnu/packages/security-token.scm
+++ b/gnu/packages/security-token.scm
@@ -858,7 +858,7 @@ devices.")
(list qtbase-5
qtsvg-5
qtdeclarative-5
- qtwebsockets
+ qtwebsockets-5
qtgraphicaleffects
qtquickcontrols2-5
pcsc-lite
diff --git a/gnu/packages/sync.scm b/gnu/packages/sync.scm
index f364195341..40385124fd 100644
--- a/gnu/packages/sync.scm
+++ b/gnu/packages/sync.scm
@@ -196,7 +196,7 @@
qtsolutions
qtsvg-5
qtwebchannel
- qtwebsockets
+ qtwebsockets-5
sqlite
xdg-utils
zlib))
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 29a3e651c9..184dca8eff 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -4864,7 +4864,7 @@ transitions, and effects and then export your film to many common formats.")
qtquickcontrols2-5
qtsvg-5
qtwebkit
- qtwebsockets
+ qtwebsockets-5
qtx11extras
sdl2))
(home-page "https://www.shotcut.org/")