aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index 044da9290c..de987b1b7f 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -215,6 +215,13 @@
;; system installation image.)
"ac_cv_path_DOT_USER_PROGRAM=dot"
+ ;; When cross-compiling, 'git' is not in $PATH
+ ;; (because it's not a native input). Thus,
+ ;; always explicitly pass its file name.
+ (string-append "ac_cv_path_GIT="
+ (search-input-file %build-inputs
+ "/bin/git"))
+
;; To avoid problems with the length of shebangs,
;; choose a fixed-width and short directory name
;; for tests.
isplay-search-paths): Likewise. (%default-options): Remove 'profile' entry. (%options) <--profile>: Keep previous values associated with 'profile' in RESULT. (guix-package)[process-actions, process-query]: Handle the possible lack of 'profile' pair in OPTS. Ludovic Courtès 2015-05-20guix package: Add optional argument to --search-paths....* guix/scripts/package.scm (search-path-environment-variables): Add #:kind parameter. Pass it to 'environment-variable-definition'. (display-search-paths): Add #:kind parameter and pass it to 'search-path-environment-variables'. (%options): Add an optional parameter for "--search-paths". (guix-package)[process-query]: Handle it. * tests/guix-package-net.sh: Adjust existing test. * tests/guix-package.sh: Adjust existing tests and add new test. * doc/guix.texi (Invoking guix package): Document it. Ludovic Courtès 2015-04-08tests: Skip 'guix-package-net.sh' when prerequisites aren't met....* tests/guix-package-net.sh: Reinstate networking and shebang test that inadvertently vanished in commit 57b8623. Ludovic Courtès 2015-04-06tests: Move 'guix package' tests that require networking to a separate file....* tests/guix-package.sh (shebang_not_too_long): Remove. Move everything below "if [networking + shebang_not_too_long]" to... * tests/guix-package-net.sh: ... here. New file. * Makefile.am (SH_TESTS): Add it. Ludovic Courtès