;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2014 Andreas Enge ;;; Copyright © 2015 Andy Wingo ;;; Copyright © 2015 Mark H Weaver ;;; Copyright © 2016 Efraim Flashner ;;; Copyright © 2017 Huang Ying ;;; Copyright © 2018 Tobias Geerinckx-Rice ;;; Copyright © 2018 Ricardo Wurmus ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If n
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/networking.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 005f925686..c22e97955c 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -4410,7 +4410,7 @@ IPv6 Internet connectivity - it also works over IPv4.")
(define-public netdiscover
(package
(name "netdiscover")
- (version "0.7")
+ (version "0.10")
(source
(origin
(method git-fetch)
@@ -4418,10 +4418,10 @@ IPv6 Internet connectivity - it also works over IPv4.")
(url "https://github.com/netdiscover-scanner/netdiscover")
(commit version)))
(sha256
- (base32 "0g8w8rlg16dsibxi4dnyn7v7r8wwi5ypd51c4w59j0ps2id0w8yj"))
+ (base32 "1ljkj280qja9rz0zwkilsa4051fdxsygjqhfch0wpkxxa5zx3prx"))
(file-name (string-append "netdiscover-" version))))
(arguments
- `(#:tests? #f)) ;; no tests
+ `(#:tests? #f)) ; no tests
(build-system gnu-build-system)
(inputs
(list libnet libpcap))
h7yv7")))) (build-system cmake-build-system) (inputs `(("polkit" ,polkit))) (propagated-inputs `(("qtbase" ,qtbase))) (native-inputs `(("pkg-config" ,pkg-config))) (arguments `(#:configure-flags (list (string-append "-DCMAKE_INSTALL_RPATH=" (assoc-ref %outputs "out") "/lib:" (assoc-ref %outputs "out") "/lib64")) #:tests? #f)) ; there is a test subdirectory, but no test target (home-page "https://api.kde.org/kdesupport-api/polkit-qt-1-apidocs/") (synopsis "Qt frontend to the polkit library") (description "Polkit-qt is a library that lets developers use the PolicyKit API through a Qt-styled API. It is mainly a wrapper around QAction and QAbstractButton that lets you integrate those two component easily with PolicyKit.") (license lgpl2.0+))) (define-public polkit-gnome (package (name "polkit-gnome") (version "0.105") (source (origin (method url-fetch) (uri (string-append "mirror://gnome/sources/" name "/" version "/" name "-" version ".tar.xz")) (sha256 (base32 "0sckmcbxyj6sbrnfc5p5lnw27ccghsid6v6wxq09mgxqcd4lk10p")))) (build-system gnu-build-system) (inputs `(("gtk+" ,gtk+) ("polkit" ,polkit))) (native-inputs `(("intltool" ,intltool) ("pkg-config" ,pkg-config))) (synopsis "Legacy polkit authentication agent for GNOME") (description "PolicyKit-gnome provides a D-Bus session bus service that is used to bring up authentication dialogs used for obtaining privileges.") (home-page "https://www.freedesktop.org/wiki/Software/polkit/") (license lgpl2.0+)))