aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm19
1 files changed, 9 insertions, 10 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index c88f98b3bb..9c45ca0c50 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -5600,23 +5600,22 @@ development tools to catch coverage problems early.")
(name "ruby-oedipus-lex")
(version "2.6.0")
(source
- (origin
- (method url-fetch)
- (uri (rubygems-uri "oedipus_lex" version))
- (sha256
- (base32
- "094nd7jd3klv45mvprfn2ivcgw8cckq3jhlly77j903vlamfi0df"))))
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "oedipus_lex" version))
+ (sha256
+ (base32
+ "094nd7jd3klv45mvprfn2ivcgw8cckq3jhlly77j903vlamfi0df"))))
(build-system ruby-build-system)
- (native-inputs
- (list ruby-hoe))
+ (native-inputs (list ruby-hoe))
(synopsis "Ruby lexer")
(description
"Oedipus Lex is a lexer generator in the same family as Rexical and Rex.
It is based primarily on generating code much like you would a hand-written
lexer. It uses StrScanner within a multi-level case statement. As such,
Oedipus matches on the first match, not the longest.")
- (home-page "https://github.com/seattlerb/oedipus_lex")
- (license license:expat)))
+ (home-page "https://github.com/seattlerb/oedipus_lex")
+ (license license:expat)))
(define-public ruby-guard
(package