about
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/haskell.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 5e99ba2287..d31cf68a17 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -6323,6 +6323,31 @@ definition lists, tables, and other features. A compatibility mode is
provided for those who need a drop-in replacement for Markdown.pl.")
(license license:gpl2+)))
+(define-public ghc-union-find
+ (package
+ (name "ghc-union-find")
+ (version "0.2")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "http://hackage.haskell.org/package/union-find/union-find-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1v7hj42j9w6jlzi56jg8rh4p58gfs1c5dx30wd1qqvn0p0mnihp6"))))
+ (build-system haskell-build-system)
+ (home-page "http://github.com/nominolo/union-find")
+ (synopsis "Efficient union and equivalence testing of sets")
+ (description
+ "The Union/Find algorithm implements these operations in (effectively)
+constant-time:
+@enumerate
+@item Check whether two elements are in the same equivalence class.
+@item Create a union of two equivalence classes.
+@item Look up the descriptor of the equivalence class.
+@end enumerate\n")
+ (license license:bsd-3)))
+
(define-public idris
(package
(name "idris")