aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/statistics.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index e09276f06f..d8cfbcb8a4 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -7537,13 +7537,13 @@ Calculates confidence intervals for the difference in proportion.")
(define-public r-desctools
(package
(name "r-desctools")
- (version "0.99.55")
+ (version "0.99.56")
(source
(origin
(method url-fetch)
(uri (cran-uri "DescTools" version))
(sha256
- (base32 "07dgif06kl2p2qzcg827y05al1k1qy21a5gkz24jbd6xds161mg5"))))
+ (base32 "1lvh19q3f4yidcxilba6bw2l2lllm6zc0aiqjgh8bvz01rq19f09"))))
(properties `((upstream-name . "DescTools")))
(build-system r-build-system)
(arguments
ble. Ludovic Courtès 2016-06-27tests: base: Add host name resolution tests....* gnu/tests/base.scm (run-basic-test)["host name resolution", "host not found"]: New tests. Ludovic Courtès 2016-06-23tests: basic: Don't hard-code the expected architecture name....* gnu/tests/base.scm (run-basic-test)["uname"]: Don't hard-code the architecture. Ludovic Courtès 2016-06-23tests: Installation test no longer requires KVM....* gnu/tests/install.scm (%test-installed-os): Use '-enable-kvm' only when /dev/kvm exists. Ludovic Courtès 2016-06-22services: Add 'mcron-service'....* gnu/services/mcron.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * gnu/tests/base.scm (%mcron-os, %test-mcron): New variables. (run-mcron-test): New procedure. * doc/guix.texi (Scheduled Job Execution): New node. Ludovic Courtès 2016-06-20tests: Add a mechanism to describe and discover system tests....* gnu/tests.scm (<system-test>): New record type. (write-system-test, test-modules, fold-system-tests) (all-system-tests): New procedures. * gnu/tests/base.scm (%test-basic-os): Turn into a <system-test>. * gnu/tests/install.scm (%test-installed-os): Likewise. * build-aux/run-system-tests.scm (%system-tests): Remove. (run-system-tests): Use 'all-system-tests'. Ludovic Courtès 2016-06-20tests: Add system installation test....* gnu/tests.scm (define-os-with-source): New macro. * gnu/tests/install.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * build-aux/run-system-tests.scm (%system-tests): Likewise. Ludovic Courtès 2016-06-20tests: base: Fully honor the OS passed to 'run-basic-test'....* gnu/tests/base.scm (run-basic-test)["uname"]: Use the host name of OS. ["shepherd services"]: Use service names from OS. (%test-basic-os): Add call to 'virtualized-operating-system'. Ludovic Courtès 2016-06-20tests: Export 'run-basic-test'....* gnu/tests/base.scm (run-basic-test): New procedure, extracted from ... (%test-basic-os): ... here. Use it. Ludovic Courtès 2016-05-08system: tests: Use 'start-service' to wait for service....* gnu/tests/base.scm (%test-basic-os): Use 'start-service' instead of a busy loop to wait for 'term-tty1'. Ludovic Courtès 2016-05-04tests: Add whole-system test....* gnu/system/vm.scm (virtualized-operating-system): Export. * gnu/tests/base.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * Makefile.am (check-system): New target. Ludovic Courtès