aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/perl.scm b/gnu/packages/perl.scm
index 0395d642f6..1a96ee237b 100644
--- a/gnu/packages/perl.scm
+++ b/gnu/packages/perl.scm
@@ -7361,15 +7361,15 @@ a minimum of effort.")
(define-public perl-test-trap
(package
(name "perl-test-trap")
- (version "v0.3.0")
+ (version "0.3.2")
(source
(origin
(method url-fetch)
(uri (string-append "mirror://cpan/authors/id/E/EB/EBHANSSEN/"
- "Test-Trap-" version ".tar.gz"))
+ "Test-Trap-v" version ".tar.gz"))
(sha256
(base32
- "05b4zc4087imwphls4yksg4chzx9yavbri301gaxas9kv1yhx13w"))))
+ "0jq54pkm4s61gk8gzxglix1ff9s0m9vi6bpfv7f63lb9qq4r76rr"))))
(build-system perl-build-system)
(native-inputs
`(("perl-module-build" ,perl-module-build)
:04 +0200'>2022-09-24substitute: Test behavior with unroutable substitute server addresses....* tests/substitute.scm (%unroutable-substitute-url): New variable. ("query narinfo signed with authorized key, unroutable URL first") ("substitute, authorized key, first substitute URL is unroutable"): New tests. Ludovic Courtès 2022-02-14publish: Do not sign the URL/Compression/FileSize narinfo fields....This will allow mirror operators to alter these non-normative bits of a narinfo without having to resign narinfos. * guix/scripts/publish.scm (narinfo-string): Remove URL/Compression/FileSize from BASE-INFO. Move them after "Signature". * tests/publish.scm ("/*.narinfo") ("/*.narinfo with properly encoded '+' sign") ("/*.narinfo with lzip + gzip") ("with cache, lzip + gzip"): Adjust accordingly. * tests/substitute.scm ("query narinfo with signature over relevant subset"): New test. Ludovic Courtès