aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ntp.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/ntp.scm b/gnu/packages/ntp.scm
index 43a8b6b045..f12bfd469b 100644
--- a/gnu/packages/ntp.scm
+++ b/gnu/packages/ntp.scm
@@ -134,14 +134,14 @@ time-stamping or reference clock, sub-microsecond accuracy is possible.")
"sntp/libevent/build-aux")))))
(native-inputs (list which pkg-config))
(inputs
- `(("openssl" ,openssl-1.1)
- ("libevent" ,libevent)
- ;; Build with POSIX capabilities support on GNU/Linux. This allows 'ntpd'
- ;; to run as non-root (when invoked with '-u'.)
- ,@(if (string-suffix? "-linux"
- (or (%current-target-system) (%current-system)))
- `(("libcap" ,libcap))
- '())))
+ (cons* openssl-1.1
+ libevent
+ ;; Build with POSIX capabilities support on GNU/Linux. This allows
+ ;; 'ntpd' to run as non-root (when invoked with '-u'.)
+ (if (string-suffix? "-linux"
+ (or (%current-target-system) (%current-system)))
+ (list libcap)
+ '())))
(arguments
`(;; Pass "--with-yielding-select=yes" so that 'configure' knows whether
;; 'select' yields when using pthreads in a cross-compilation context.