aboutsummaryrefslogtreecommitdiff
diff options
on value='7'>7
context:2023-07-26system: accounts: Export <user-account>.Maxim Cournoyer
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm23
-rw-r--r--gnu/packages/golang.scm22
2 files changed, 23 insertions, 22 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index d7fd47b79c..2d534b8dcd 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -1980,6 +1980,29 @@ gist (https://gist.github.com/kballard/272720).")
more complicated parallel cases.")
(license license:expat)))
+(define-public go-github-com-deckarep-golang-set
+ (package
+ (name "go-github-com-deckarep-golang-set")
+ (version "1.7.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri
+ (git-reference
+ (url "https://github.com/deckarep/golang-set")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0y64c0p6a7ww5jp6adm6fm97vsni86njw8wkwxfmciy466vhl0lf"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "github.com/deckarep/golang-set"))
+ (home-page "https://github.com/deckarep/golang-set")
+ (synopsis "Set type for Go")
+ (description
+ "Set is the set collection for the Go language.")
+ (license license:expat)))
+
(define-public go-github-com-dennwc-varint
(package
(name "go-github-com-dennwc-varint")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index d446dd6447..4c8059aa0a 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1697,28 +1697,6 @@ functionality for functions that may fail. It includes various customizable
retry strategies, such as fixed delay, backoff delay, and random delay.")
(license license:expat))))
-(define-public go-github-com-deckarep-golang-set
- (package
- (name "go-github-com-deckarep-golang-set")
- (version "1.7.1")
- (source
- (origin
- (method git-fetch)
- (uri
- (git-reference
- (url "https://github.com/deckarep/golang-set")
- (commit (string-append "v" version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0y64c0p6a7ww5jp6adm6fm97vsni86njw8wkwxfmciy466vhl0lf"))))
- (build-system go-build-system)
- (arguments
- `(#:import-path "github.com/deckarep/golang-set"))
- (home-page "https://github.com/deckarep/golang-set")
- (synopsis "Set type for Go")
- (description "Set is the set collection for the Go language.")
- (license license:expat)))
-
(define-public go-howett-net-plist
(package
(name "go-howett-net-plist")