aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bioinformatics.scm41
1 files changed, 21 insertions, 20 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 2c8dc8f399..354a809c44 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -6672,27 +6672,28 @@ also known as views, in a controlled vocabulary.")
(define-public r-bookdown
(package
- (name "r-bookdown")
- (version "0.6")
- (source (origin
- (method url-fetch)
- (uri (cran-uri "bookdown" version))
- (sha256
- (base32
- "1pxxln42kvzl38fjprg6hcnyh1kij75fpj70vwp5hp5il813aszc"))))
- (build-system r-build-system)
- (propagated-inputs
- `(("r-htmltools" ,r-htmltools)
- ("r-knitr" ,r-knitr)
- ("r-rmarkdown" ,r-rmarkdown)
- ("r-yaml" ,r-yaml)
- ("r-xfun" ,r-xfun)
- ("ghc-pandoc" ,ghc-pandoc)))
- (home-page "https://github.com/rstudio/bookdown")
- (synopsis "Authoring books and technical documents with R markdown")
- (description "This package provides output formats and utilities for
+ (name "r-bookdown")
+ (version "0.7")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "bookdown" version))
+ (sha256
+ (base32
+ "1b3fw1f41zph5yw3kynb47aijq53vhaa6mnnvxly72zamyzdf95q"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-htmltools" ,r-htmltools)
+ ("r-knitr" ,r-knitr)
+ ("r-rmarkdown" ,r-rmarkdown)
+ ("r-tinytex" ,r-tinytex)
+ ("r-yaml" ,r-yaml)
+ ("r-xfun" ,r-xfun)
+ ("ghc-pandoc" ,ghc-pandoc)))
+ (home-page "https://github.com/rstudio/bookdown")
+ (synopsis "Authoring books and technical documents with R markdown")
+ (description "This package provides output formats and utilities for
authoring books and technical documents with R Markdown.")
- (license license:gpl3)))
+ (license license:gpl3)))
(define-public r-biocstyle
(package
ith-comments: dot notation") ("((a . 1) (b . 2))", "(a b c . boom)"): New tests. Ludovic Courtès 2022-01-10style: '-S format' canonicalizes comments....* guix/scripts/style.scm (canonicalize-comment): New procedure. (pretty-print-with-comments): Add #:format-comment. and honor it. (object->string*): Add 'args' and honor them. (format-package-definition): Pass #:format-comment to 'object->string*'. * tests/style.scm ("pretty-print-with-comments, canonicalize-comment"): New test. Ludovic Courtès 2022-01-10style: Add '--styling' option....* guix/scripts/style.scm (format-package-definition): New procedure. (%options, show-help): Add "--styling". (%default-options): Add 'styling-procedure'. (guix-style): Honor it. * tests/style.scm (with-test-package) ("input labels, 'safe' policy") ("input labels, 'safe' policy, nothing changed") ("input labels, margin comment") ("input labels, margin comment on long list") ("input labels, line comment") ("input labels, modify-inputs and margin comment"): Pass "-S inputs". * etc/indent-code.el: Remove. * doc/contributing.texi (Formatting Code): Mention "guix style" instead of "etc/indent-code.el". (Submitting Patches): Add item for "guix style". * doc/guix.texi (Invoking guix style): Document "-S" and update. Ludovic Courtès 2022-01-10style: Add support for "newline forms"....This allows us to express cases where a newline should be inserted immediately after the head symbol of a list. * guix/scripts/style.scm (%newline-forms): New variable. (newline-form?): New procedure. (pretty-print-with-comments): Handle "newline forms". * tests/style.scm: Add test. Ludovic Courtès 2022-01-10style: Allow special forms to be scoped....* guix/scripts/style.scm (vhashq): Add clause for 'lst, and change default clause. (%special-forms): Add context for 'add-after and 'add-before. Add 'replace. (prefix?, special-form-lead): New procedures. (special-form?): Remove. (pretty-print-with-comments): Add 'context' to the threaded state. Adjust 'print-sequence' and adjust 'loop' calls accordingly. * tests/style.scm: Add tests for 'replace. Ludovic Courtès 2022-01-10style: Improve pretty printer and add tests....* guix/scripts/style.scm (vhashq): New macro. (%special-forms): New variable. (special-form?): New procedure. (pretty-print-with-comments): Add many clauses and tweak existing rules. * tests/style.scm (test-pretty-print): New macro. <top level>: Add 'test-pretty-print' tests. Ludovic Courtès 2021-07-11Add 'guix style'....* guix/scripts/style.scm, tests/style.scm: New files. * Makefile.am (MODULES, SCM_TESTS): Add them. * po/guix/POTFILES.in: Add 'guix/scripts/style.scm'. * doc/guix.texi (Invoking guix style): New node. (package Reference): Reference it. (Invoking guix lint): Likewise. Ludovic Courtès