aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gnome.scm15
1 files changed, 10 insertions, 5 deletions
diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index a26688d8b8..2d825081f6 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -5095,16 +5095,20 @@ libxml2.")
(sha256
(base32
"1s2xzrwcjhfb4ra8jrxqfycs1jpv97id0f6idb2h6vjkspxbjy23"))))
- (build-system gnu-build-system)
+ (build-system glib-or-gtk-build-system)
(arguments
'(#:configure-flags
`("--without-plymouth"
+ "--disable-systemd-journal"
"--localstatedir=/var"
,(string-append "--with-default-path="
(string-join '("/run/setuid-programs"
"/run/current-system/profile/bin"
"/run/current-system/profile/sbin")
- ":")))
+ ":"))
+ ;; Put GDM in bindir so that glib-or-gtk-build-system wraps the
+ ;; XDG_DATA_DIRS so that it finds its schemas.
+ "--sbindir" ,(string-append (assoc-ref %outputs "out") "/bin"))
#:phases
(modify-phases %standard-phases
(add-before
@@ -5122,9 +5126,10 @@ libxml2.")
"libgdm/gdm-user-switching.c")
(("#include <systemd/sd-login\\.h>")
"#include <elogind/sd-login.h>"))
- ;; Avoid checking SYSTEMD using pkg-config.
- (setenv "SYSTEMD_CFLAGS" " ")
- (setenv "SYSTEMD_LIBS" "-lelogind")
+ ;; Check for elogind.
+ (substitute* '("configure")
+ (("libsystemd")
+ "libelogind"))
;; Look for system-installed sessions in
;; /run/current-system/profile/share.
(substitute* '("libgdm/gdm-sessions.c"
m: Use 'file-append' to denote file names....Ludovic Courtès 2016-07-21services: Export *-service-type and *-configuration....Tomáš Čech 2016-06-16gnu: services: Add mysql-service....宋文武 2016-03-23services: postgresql: Use syslog....Ludovic Courtès 2016-02-10gnu: Fix syntax error in postgresql-service....Leo Famulari 2016-01-29services: Rename 'dmd' services to 'shepherd'....Alex Kost 2016-01-29Rename (gnu services dmd) to (gnu services shepherd)....Alex Kost 2015-10-10services: Introduce extensible services....Ludovic Courtès 2015-10-10system: Make service procedures non-monadic....Ludovic Courtès 2015-05-07gnu: Add postgresql-service....David Thompson