aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 558f46f673..6199513e1c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -1145,16 +1145,18 @@ from a docstring rather than the other way around.")
(define-public python-array-api-compat
(package
(name "python-array-api-compat")
- (version "1.6")
+ (version "1.9.1")
(source
(origin
(method url-fetch)
(uri (pypi-uri "array_api_compat" version))
(sha256
- (base32 "1bvn92v52h8p2zpinwv5bl1314kdjw3msalj91nczfdbrmay78bl"))))
+ (base32 "1a4y6ph3gx5fc2q74mkwc239d26b3yvlawc6ifxsay9wr4lbifhp"))))
(build-system pyproject-build-system)
;; Tests would require all supported array libraries, including pytorch
(arguments (list #:tests? #false))
+ (native-inputs
+ (list python-setuptools python-wheel))
(propagated-inputs (list python-numpy))
(home-page "https://data-apis.org/array-api-compat/")
(synopsis "Array API compatibility wrapper for NumPy et al")