aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/sphinx.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/sphinx.scm b/gnu/packages/sphinx.scm
index b22a288234..4b2e12adc4 100644
--- a/gnu/packages/sphinx.scm
+++ b/gnu/packages/sphinx.scm
@@ -184,7 +184,15 @@ sources.")
"not test_latex_images"
;; XXX: Not clear why this fails with a version comparison
;; failure.
- " and not test_needs_sphinx"))
+ " and not test_needs_sphinx"
+ ;; This is a harmless failure. The expected output looks for a
+ ;; long string that happens to contain a literal space
+ ;; character, but in the actual output the space character is
+ ;; wrapped in <span class="w"> </span>.
+ " and not test_viewcode"
+ ;; These fail with pygments 2.10+. They are harmless.
+ " and not test_additional_targets_should_not_be_translated"
+ " and not test_additional_targets_should_be_translated"))
#:phases
'(modify-phases %standard-phases
(add-before 'check 'pre-check