aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index c48867ed47..fd8bf69322 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -4286,4 +4286,32 @@ suffix comparison, rather than the string-based or tree-based approaches.")
various ways. It is a Go implementation of some string manipulation libraries
of Java Apache Commons.")
(license license:asl2.0)))
+
+(define-public go-github-com-masterminds-semver
+ (package
+ (name "go-github-com-masterminds-semver")
+ (version "3.1.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/Masterminds/semver")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1g1wizfdy29d02l9dh8gsb029yr4m4swp13swf0pnh9ryh5f1msz"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/Masterminds/semver"))
+ (home-page "https://github.com/Masterminds/semver/")
+ (synopsis "@code{semver} helps to work with semantic versions")
+ (description "The semver package provides the ability to work with
+semantic versions. Specifically it provides the ability to:
+@itemize
+@item Parse semantic versions
+@item Sort semantic versions
+@item Check if a semantic version fits within a set of constraints
+@item Optionally work with a @code{v} prefix
+@end itemize\n")
+ (license license:expat)))
(license license:expat)))