aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-gtk.scm35
1 files changed, 28 insertions, 7 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 9e41ffc774..9a1b407ff0 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -3343,24 +3343,24 @@ library.")
(("rust-shell-words" ,rust-shell-words-0.1)
("rust-tempfile" ,rust-tempfile-3))))))
-(define-public rust-pangocairo-0.18
+(define-public rust-pangocairo-0.19
(package
(name "rust-pangocairo")
- (version "0.18.0")
+ (version "0.19.8")
(source
(origin
(method url-fetch)
(uri (crate-uri "pangocairo" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "199qdgw5mf1vbqmslscy1qzz0szw2dcd21p6z61wzjngm64na0sp"))))
+ (base32 "1n8wrqy260zpfiifb2n10mbsv3kbrvxm1z7pv8b4w77c08yb9j74"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs (("rust-cairo-rs" ,rust-cairo-rs-0.18)
- ("rust-glib" ,rust-glib-0.18)
+ `(#:cargo-inputs (("rust-cairo-rs" ,rust-cairo-rs-0.19)
+ ("rust-glib" ,rust-glib-0.19)
("rust-libc" ,rust-libc-0.2)
- ("rust-pango" ,rust-pango-0.18)
- ("rust-pangocairo-sys" ,rust-pangocairo-sys-0.18))
+ ("rust-pango" ,rust-pango-0.19)
+ ("rust-pangocairo-sys" ,rust-pangocairo-sys-0.19))
#:cargo-development-inputs
(("rust-gir-format-check" ,rust-gir-format-check-0.1))))
(native-inputs (list pkg-config))
@@ -3371,6 +3371,27 @@ library.")
"This package provides Rust bindings for the @code{PangoCairo} library.")
(license license:expat)))
+(define-public rust-pangocairo-0.18
+ (package
+ (inherit rust-pangocairo-0.19)
+ (name "rust-pangocairo")
+ (version "0.18.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "pangocairo" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "199qdgw5mf1vbqmslscy1qzz0szw2dcd21p6z61wzjngm64na0sp"))))
+ (arguments
+ `(#:cargo-inputs (("rust-cairo-rs" ,rust-cairo-rs-0.18)
+ ("rust-glib" ,rust-glib-0.18)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pango" ,rust-pango-0.18)
+ ("rust-pangocairo-sys" ,rust-pangocairo-sys-0.18))
+ #:cargo-development-inputs
+ (("rust-gir-format-check" ,rust-gir-format-check-0.1))))))
+
(define-public rust-pangocairo-0.17
(package
(inherit rust-pangocairo-0.18)
92a346560e3f0 Janneke Nieuwenhuizen 2024-04-01nls: Update translations....* po/guix/ar.po: New file. * po/guix/LINGUAS: Add 'ar'. * po/doc/guix-cookbook.pt_BR.po: New file. * po/doc/local.mk: Add 'pt_BR' cookbook. * doc/local.mk: Add 'pt_BR' cookbook. * doc/htmlxref.cnf: Update URLs for cookbook. * doc/build.scm (%cookbook-languages): Add 'ko', 'pt_BR'. * doc/guix-cookbook.texi (Top): Mention 'ko', 'pt_BR' cookbook. Change-Id: Id1846ca100263b3fc1fa2ed52654c670270ee809 Florian Pelz 2024-02-29nls: Update translations....Change-Id: Ic1506db5813880153b6def005011618dc4529e8f Florian Pelz 2024-02-01nls: Update translations....Change-Id: I42b5d41bdd5cd1b096c977e132b7a85992223402 Florian Pelz 2024-01-28home: Add home-dotfiles-service....* gnu/home/service/dotfiles.scm: New file; * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/guix/POTFILES.in: Add it. * doc/guix.texi (Essential Home Services): Document it. Change-Id: I6769169cfacefc3842faa5b31bee081c56c28743 Co-authored-by: Ludovic Courtès <ludo@gnu.org> Giacomo Leidi 2024-01-01nls: Update translations....Change-Id: Ib407fd37896cc8653f5bfb1f76dba9dc775c8c10 Florian Pelz 2023-12-01nls: Update translations....* po/guix/ca.po: New file. * po/guix/LINGUAS: Add ca.$ Change-Id: Ibae3f58ba702d7c5a4fafdd59a19f70aa8e18212 Florian Pelz 2023-10-31nls: Update translations....Change-Id: I432aec0ea31ead192d6444c96dc42038f5c7ab9a Florian Pelz 2023-10-05doc: Fix channel name typo....When the manual has "variant-personal-packages", it actually refers to the channel "variant-packages", as it is named so elsewhere. To correct this, I ran the command grep -r -l variant-personal-packages | xargs \ sed -i 's/variang-personal-packages/variant-packages/g' * doc/guix.texi (Specifying Additional Channels): Fix channel name typo. * po/doc/guix-manual.de.po: Fix channel name typo. * po/doc/guix-manual.es.po: Fix channel name typo. * po/doc/guix-manual.fr.po: Fix channel name typo. * po/doc/guix-manual.pt_BR.po: Fix channel name typo. * po/doc/guix-manual.ru.po: Fix channel name typo. * po/doc/guix-manual.zh_CN.po: Fix channel name typo. Signed-off-by: Nikolaos Chatzikonstantinou <nchatz314@gmail.com> Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nikolaos Chatzikonstantinou 2023-09-30nls: Update translations.Florian Pelz 2023-08-31nls: Update translations.Florian Pelz 2023-07-31nls: Update translations.Florian Pelz 2023-06-30nls: Update translations....* po/packages/ja.po: New file. * po/packages/LINGUAS: Add it. Florian Pelz 2023-06-18Add 'guix locate'....* guix/scripts/locate.scm, tests/guix-locate.sh: New files. * Makefile.am (MODULES): Add 'guix/scripts/locate.scm'. (SH_TESTS): Add 'tests/guix-locate.sh'. * po/guix/POTFILES.in: Add it. * doc/guix.texi (Invoking guix locate): New node. Co-authored-by: Antoine R. Dumont <antoine.romain.dumont@gmail.com> Ludovic Courtès 2023-05-31nls: Update translation keys for guix gc....* po/*/*.po (guix/scripts/gc.scm): Round MiBs in user feedback. Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de> Remco van 't Veer 2023-05-31nls: Update translations....* doc/guix-cookbook.texi (Top): Mention Slovak. Florian Pelz 2023-04-08nls: Make sure gnu/home/services/*.scm files are translatable....* po/guix/POTFILES.in: Add missing gnu/home/services/*.scm files. Ludovic Courtès 2023-03-16gnu: home: services: Add home-kodi-service-type....* gnu/home/services/media.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/guix/POTFILES.in: Likewise. * doc/guix.texi (Media Home Services): Document it in new subsection. Jan (janneke) Nieuwenhuizen 2023-03-16gnu: home: services: Add home-znc-service-type....* gnu/home/services/messaging.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/guix/POTFILES.in: Likewise. * doc/guix.texi (Messaging Home Services): Document it in new subsection. Jan (janneke) Nieuwenhuizen 2023-03-07nls: Fix more Texinfo Italiano....po/guix/it.po: Fix `@esempio`, `@sempio`, `@fine`. Julien Lepiller 2023-03-07nls: Update translations.Julien Lepiller 2023-02-26nls: Fix more Texinfo Italiano....* po/guix/it.po: Fix ‘@opzione’, ‘@comando’. Tobias Geerinckx-Rice 2023-02-26nls: Fix typo in Italian translation....I will, of course, fix this in Weblate or find someone who can, but this currently breaks ‘guix system search cups’. * po/guix/it.po: Fix ‘@dnf’ typo. Reported by tux_life in #guix: https://issues.guix.gnu.org/61961 Tobias Geerinckx-Rice 2023-02-03gnu: Remove key-mon.scm....The file is empty. * gnu/packages/key-mon.scm: Remove file. * gnu/local.mk (GNU_SYSTEM_MODULES): Remove it. * po/packages/POTFILES.in: Remove it. Julien Lepiller 2023-01-05nls: Update translations....* po/guix/ka.po: New file. * po/guix/LINGUAS: Add it. * po/packages/uk.po: New file. * po/packages/LINGUAS: Add it. Julien Lepiller 2022-12-15doc: Use VM image file name consistently....Previously, what "/tmp/qemu-image" refers to could be unclear at first. * doc/guix.texi (Running Guix in a VM): Use the original image file name instead of /tmp/qemu-image. * po/doc/guix-manual.de.po, po/doc/guix-manual.es.po, po/doc/guix-manual.fr.po, po/doc/guix-manual.pt_BR.po, po/doc/guix-manual.ru.po, po/doc/guix-manual.zh_CN.po: Adjust accordingly. Ludovic Courtès 2022-12-04nls: Update translations....po/packages/vi.po: New file. po/packages/LINGUAS: Add it. Julien Lepiller 2022-11-20scripts: Use translations for guix.pot for service descriptions....Previously, service descriptions appeared in both guix.pot and packages.pot, but only translations of packages.pot were used. Now, translations are only done with guix.pot. This is better, because translators are more likely to translate guix.pot, and is also easier, because files in gnu/{home/,}services need to be in po/guix/POTFILES.in anyway and po/guix/Makevars already acts on the 'description' keyword because of lint checkers. * guix/scripts/home.scm (service-type-description-string): Use translations from guix.pot. * guix/scripts/system/search.scm (service-type-description-string) (service-type->recutils): Likewise. * po/packages/POTFILES.in: Move files in gnu/services to ... * po/guix/POTFILES.in: ... here. pelzflorian (Florian Pelz)