aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/javascript.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/javascript.scm b/gnu/packages/javascript.scm
index a1c0d9ad01..c6e7443f85 100644
--- a/gnu/packages/javascript.scm
+++ b/gnu/packages/javascript.scm
@@ -843,8 +843,9 @@ roots, or wrestle with obscure build systems.")
#:phases #~(modify-phases %standard-phases
(delete 'configure)
(replace 'check
- (lambda _
- (invoke "make" "microbench"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "make" "microbench")))))))
(home-page "https://bellard.org/quickjs/")
(synopsis "Small embeddable Javascript engine")
(description "QuickJS supports the ES2020 specification including modules,