aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/guile-xyz.scm55
1 files changed, 55 insertions, 0 deletions
diff --git a/gnu/packages/guile-xyz.scm b/gnu/packages/guile-xyz.scm
index 6204261cd5..0178ca3970 100644
--- a/gnu/packages/guile-xyz.scm
+++ b/gnu/packages/guile-xyz.scm
@@ -47,6 +47,9 @@
;;; Copyright © 2022 Evgeny Pisemsky <mail@pisemsky.site>
;;; Copyright © 2022 jgart <jgart@dismail.de>
;;; Copyright © 2023 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Wojtek Kosior <koszko@koszko.org>
+;;; Additions and modifications by Wojtek Kosior are additionally
+;;; dual-licensed under the Creative Commons Zero v1.0.
;;; Copyright © 2024 Ilya Chernyshov <ichernyshovvv@gmail.com>
;;; Copyright © 2024 Artyom Bologov <mail@aartaka.me>
;;; Copyright © 2024 Felix Lechner <felix.lechner@lease-up.com>
@@ -4649,6 +4652,58 @@ run SRFI 64 test suites. It gives Automake insight into the individual
tests being run, resulting clearer and more specific output.")
(license license:gpl3+)))
+(define-public guile-myra-test-utils
+ (package
+ (name "guile-myra-test-utils")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.koszko.org/myra-test-utils")
+ (commit "dae06b96848965f7d1b7e2f954d2f8faea50d9cc")))
+ (sha256
+ (base32
+ "1qdm3x0y03mqa7kpmdg7dzw1443ah5lpbs35y3fj34jc2p7yy19n"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:tests? #f
+ #:modules `(((guix build guile-build-system)
+ #:select (target-guile-effective-version))
+ ,@%gnu-build-system-modules)
+ #:imported-modules `((guix build guile-build-system)
+ ,@%gnu-build-system-modules)
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'install 'wrap-executables
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (_ (format #t "out: ~s~%" out))
+ (version (target-guile-effective-version))
+ (_ (format #t "version: ~s~%" version))
+ (bin (string-append out "/bin"))
+ (scm (string-append out "/share/guile/site/" version))
+ (go (string-append out "/lib/guile/" version
+ "/site-ccache")))
+ (wrap-program (string-append bin "/guile-test-driver")
+ `("GUILE_LOAD_PATH" prefix (,scm))
+ `("GUILE_LOAD_COMPILED_PATH" prefix (,go)))))))))
+ (native-inputs
+ (list autoconf automake guile-3.0 pkg-config lawrence-boilerplate))
+ (inputs
+ (list guile-3.0))
+ (home-page "https://git.koszko.org/myra-test-utils/about")
+ (synopsis "Extra facilities for running SRFI 64 test suites in GNU Guile")
+ (description "One part of the package — a test driver extracted from GNU
+Guix — allows SRFI-64 tests to be easily executed through Automake's
+@command{make check}. This is the same driver as also distributed with
+Automake, albeit with some extra improvements.
+
+The other part — @code{(myra-test-utils)} module — exports improved variants
+of SRFI-64's @code{test-*} forms as well as some extra facilities to aid with
+writing tests.")
+ (license license:gpl3+)))
+
(define-public guile-semver
(package
(name "guile-semver")