;;; GNU Guix --- Functional package management for GNU ;;; Copyright © 2013, 2014, 2015, 2016, 2018 Ludovic Courtès ;;; Copyright © 2015, 2017 Mark H Weaver ;;; Copyright © 2015 Eric Dvorsak ;;; Copyright © 2016 David Thompson ;;; Copyright © 2017, 2019, 2020 Marius Bakke ;;; Copyright © 2017 Efraim Flashner ;;; Copyright © 2018, 2019 Tobias Geerinckx-Rice ;;; Copyright © 2019 Pierre Neidhardt ;;; ;;; This file is part of GNU Guix. ;;; ;;; GNU Guix is free software; you can redistribute it and/or modify it ;;; under the terms of the GNU General Public License as published by ;;; the Free Software Foundation; either version 3 of the License, or (at ;;; your option) any later version. ;;; ;;; GNU Guix is distributed in the hope that it will be useful, but ;;; WITHOUT ANY WARRANTY; without even the implied warranty of ;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;
aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 50705416a0..d8a9ffeaed 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -6787,7 +6787,7 @@ It should enable you to implement low-level X11 applications.")
(define-public emacs-exwm
(package
(name "emacs-exwm")
- (version "0.20")
+ (version "0.21")
(synopsis "Emacs X window manager")
(source (origin
(method url-fetch)
@@ -6795,7 +6795,7 @@ It should enable you to implement low-level X11 applications.")
version ".tar"))
(sha256
(base32
- "0nhhzbkm0mkj7sd1dy2c19cmn56gyaj9nl8kgy86h4fp63hjaz04"))))
+ "07ng1pgsnc3isfsyzh2gfc7391p9il8lb5xqf1z6yqn20w7k6xzj"))))
(build-system emacs-build-system)
(propagated-inputs
`(("emacs-xelb" ,emacs-xelb)))
e48c827f6b103e05c3f0e78b79a9") (revision "3")) ;; When upgrading Julia, also upgrade this. Get the commit from ;; https://github.com/JuliaLang/julia/blob/v1.6.1/deps/libuv.version (package (inherit libuv) (name "libuv-julia") (version (git-version "2.0.0" revision commit)) (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/JuliaLang/libuv") (commit commit))) (file-name (git-file-name name version)) (sha256 (base32 "1kqpn19d20aka30h6q5h8lnzyp0vw0xzgx0wm4w2r5j6yf76m2hr")))) (home-page "https://github.com/JuliaLang/libuv") (properties '((hidden? . #t)))))) (define-public perl-anyevent (package (name "perl-anyevent") (version "7.17") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/" "AnyEvent-" version ".tar.gz")) (sha256 (base32 "11drlj8r02czhjgzkb39axnr8zzyp506r043xfmf93q9kilfmgjh")))) (build-system perl-build-system) (native-inputs (list perl-canary-stability)) (propagated-inputs (list perl-async-interrupt perl-ev perl-guard perl-json perl-json-xs perl-net-ssleay perl-task-weaken)) (home-page "https://metacpan.org/release/AnyEvent") (synopsis "API for I/O, timer, signal, child process and completion events") (description "This module allows using a variety of events without forcing module authors to pick a specific event loop, and without noticeable overhead. Currently supported event loops are EV, Event, Glib/Gtk2, Tk, Qt, @code{Event::Lib}, Irssi, @code{IO::Async} and POE (and thus also WxWidgets and Prima). It also comes with a very fast Pure Perl event loop that does not rely on XS.") (license perl-license))) (define-public perl-ev (package (name "perl-ev") (version "4.31") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/M/ML/MLEHMANN/EV-" version ".tar.gz")) (sha256 (base32 "1jxlhnvrqim39977zwavjrcbdf9bifb46pwaxvm0s8klq121kjwb")) (modules '((guix build utils))) (snippet '(begin ;; Drop bundled libev. (delete-file-recursively "libev") #t)))) (build-system perl-build-system) (arguments '(#:phases (modify-phases %standard-phases (add-after 'unpack 'unpack-libev ;; This package requires the libev *sources* in order ;; to build. Unpack system libev here... (lambda* (#:key inputs #:allow-other-keys) (mkdir "./libev") (invoke "tar" "-xf" (assoc-ref inputs "libev-source") "-C" "./libev" "--strip-components=1")))))) (native-inputs `(("libev-source" ,(package-source libev)) ("perl-canary-stability" ,perl-canary-stability))) (propagated-inputs (list perl-common-sense)) (home-page "https://metacpan.org/release/EV") (synopsis "Perl interface to libev") (description "This module provides an interface to @code{libev}, a high performance full-featured event loop. It can be used through the @code{AnyEvent} module and still be faster than other event loops currently supported in Perl.") (license perl-license))) (define-public perl-rpc-epc-service (package (name "perl-rpc-epc-service") (version "0.0.11") (source (origin (method url-fetch) (uri (string-append "mirror://cpan/authors/id/K/KI/KIWANAMI/RPC-EPC-Service-" "v" version ".tar.gz")) (sha256 (base32 "1qwb284z4ig3xzy21m1b3w8bkb8k6l2ij6cjz93znn2j6qs42pwp")))) (build-system perl-build-system) (native-inputs (list perl-module-build perl-test-simple)) (propagated-inputs (list perl-anyevent perl-data-sexpression)) (arguments ;; Tests seem to fail because they try to start a server. `(#:tests? #f)) (home-page "https://metacpan.org/release/RPC-EPC-Service") (synopsis "Asynchronous remote procedure stack") (description "RPC::EPC::Service enables to connect the other process with the S-expression protocol, like the Swank protocol of the SLIME.") (license perl-license)))