aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/perl-check.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/perl-check.scm b/gnu/packages/perl-check.scm
index 2399b073cd..10583822f7 100644
--- a/gnu/packages/perl-check.scm
+++ b/gnu/packages/perl-check.scm
@@ -572,6 +572,34 @@ testing exception-throwing code with about the same amount of typing.")
attributes.")
(license perl-license)))
+(define-public perl-test-file-contents
+ (package
+ (name "perl-test-file-contents")
+ (version "0.23")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "mirror://cpan/authors/id/D/DW/DWHEELER/Test-File-Contents-"
+ version
+ ".tar.gz"))
+ (sha256
+ (base32
+ "0g8zgfyw84181snw7ghahnl9r4lrmlfj7zwi76sv8d0bj7xssvyd"))))
+ (build-system perl-build-system)
+ (native-inputs
+ `(("perl-module-build" ,perl-module-build)))
+ (propagated-inputs
+ `(("perl-test-pod" ,perl-test-pod)
+ ("perl-test-pod-coverage" ,perl-test-pod-coverage)
+ ("perl-text-diff" ,perl-text-diff)))
+ (home-page "https://metacpan.org/release/Test-File-Contents")
+ (synopsis "Test routines for examining the contents of files")
+ (description
+ "@{Test::File::Contents} provides functions for testing the contents of
+files.")
+ (license perl-license)))
+
(define-public perl-test-file-sharedir-dist
(package
(name "perl-test-file-sharedir-dist")
Courtès 2019-09-08daemon: Run 'guix offload' directly....* nix/scripts/offload.in: Remove. * nix/local.mk (nodist_pkglibexec_SCRIPTS) [BUILD_DAEMON_OFFLOAD]: Remove 'scripts/offload'. * config-daemon.ac: Don't output 'nix/scripts/offload'. * build-aux/pre-inst-env.in: Don't set 'NIX_BUILD_HOOK'. * nix/libstore/build.cc (HookInstance::HookInstance): Run 'guix offload'. (DerivationGoal::tryBuildHook): Remove reference to 'NIX_BUILD_HOOK'. * nix/nix-daemon/guix-daemon.cc (main) [HAVE_DAEMON_OFFLOAD_HOOK]: Don't set 'NIX_BUILD_HOOK'. * nix/nix-daemon/nix-daemon.cc (performOp) [!HAVE_DAEMON_OFFLOAD_HOOK]: Leave 'settings.useBuildHook' unchanged. Ludovic Courtès