aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/enlightenment.scm13
1 files changed, 11 insertions, 2 deletions
diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index b62ab5f6f5..512dd9b099 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -53,6 +53,7 @@
#:use-module (gnu packages python)
#:use-module (gnu packages tls)
#:use-module (gnu packages video)
+ #:use-module (gnu packages xdisorg)
#:use-module (gnu packages xorg))
(define-public efl
@@ -101,11 +102,11 @@
("libxscrnsaver" ,libxscrnsaver)
("libxtst" ,libxtst)
("lz4" ,lz4)
- ("mesa" ,mesa)
("openjpeg" ,openjpeg-1)
("poppler" ,poppler)
("printproto" ,printproto)
("scrnsaverproto" ,scrnsaverproto)
+ ("wayland-protocols" ,wayland-protocols)
("xextproto" ,xextproto)
("xinput" ,xinput)
("xpr" ,xpr)
@@ -122,11 +123,15 @@
("glib" ,glib) ; ecore.pc, ecore-cxx.pc
("harfbuzz" ,harfbuzz) ; evas.pc, evas-cxx.pc
("luajit" ,luajit) ; elua.pc, evas.pc, evas-cxx.pc
+ ("libinput" ,libinput) ; elput.pc
("libpng" ,libpng) ; evas.pc, evas-cxx.pc
("libsndfile" ,libsndfile) ; ecore-audio.pc, ecore-audio-cxx.pc
+ ("libxkbcommon" ,libxkbcommon) ; ecore-wl2.pc, elementary.pc, elput.pc
+ ("mesa" ,mesa) ; ecore-drm2.pc
("openssl" ,openssl) ; ecore-con.pc, eet.pc, eet-cxx.pc, emile.pc
("pulseaudio" ,pulseaudio) ; ecore-audio.pc, ecore-audio-cxx.pc
("util-linux" ,util-linux) ; mount: eeze.pc
+ ("wayland" ,wayland) ; ecore-wl2.pc, elementary.pc
("zlib" ,zlib))) ; eet.pc, eet-cxx.pc, emile.pc
(arguments
`(#:configure-flags '("--disable-silent-rules"
@@ -137,7 +142,11 @@
"--enable-multisense"
"--with-opengl=es"
"--enable-egl"
- "--enable-harfbuzz")
+ "--enable-harfbuzz"
+ ;; for wayland
+ "--enable-wayland"
+ "--enable-elput"
+ "--enable-drm")
#:phases
(modify-phases %standard-phases
(add-after 'unpack 'set-home-directory
nu/services/docker.scm (docker-configuration): Likewise. * gnu/services/file-sharing.scm (transmission-daemon-configuration): Likewise. * gnu/services/getmail.scm (getmail-configuration): Likewise. * gnu/services/mail.scm (dovecot-configuration) (opaque-dovecot-configuration): Likewise. * gnu/services/messaging.scm (prosody-configuration) (opaque-prosody-configuration): Likewise. * gnu/services/monitoring.scm (zabbix-server-configuration) (zabbix-agent-configuration): Likewise. * gnu/services/networking.scm (opendht-configuration): Likewise. * gnu/services/pm.scm (tlp-configuration): Likewise. * gnu/services/telephony.scm (jami-configuration): Likewise. * gnu/services/virtualization.scm (libvirt-configuration) (qemu-guest-agent-configuration): Likewise. * gnu/services/vpn.scm (openvpn-client-configuration): Likewise. Tobias Geerinckx-Rice 2021-02-12services: Add transmission-daemon service....* gnu/services/file-sharing.scm: New file. * gnu/local.mk (GNU_SYSTEM_MODULES): Add it. * po/packages/POTFILES.in: Add it. * tests/services/file-sharing.scm: New file. * Makefile.am (SCM_TESTS): Add it. * doc/guix.texi (File-Sharing Services): New section. Signed-off-by: 宋文武 <iyzsong@member.fsf.org> Simon South