aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/version-control.scm38
1 files changed, 38 insertions, 0 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 0657df67a1..0dabb2daa0 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -552,6 +552,44 @@ collaboration using typical untrusted file hosts or services.")
a built-in cache to decrease server I/O pressure.")
(license license:gpl2)))
+(define-public python-ghp-import
+ (package
+ (name "python-ghp-import")
+ (version "0.5.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://github.com/davisp/ghp-import/archive/"
+ version ".tar.gz"))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0x887v690xsac2hzjkpbvp3a6crh3m08mqbk3nb4xwc9dnk869q7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:phases (modify-phases %standard-phases
+ (add-after 'install 'install-documentation
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (doc (string-append out "/share/doc"))
+ (licenses (string-append out "/share/licenses")))
+ (install-file "README.md" doc)
+ (install-file "LICENSE" licenses)))))))
+ (home-page "https://github.com/davisp/ghp-import")
+ (synopsis "Copy directory to the gh-pages branch")
+ (description "Script that copies a directory to the gh-pages branch (by
+default) of the repository.")
+
+ ;; See <https://bugs.gnu.org/27913>.
+ (license (license:non-copyleft
+ "https://raw.githubusercontent.com/davisp/ghp-import/master/LICENSE"
+ "Tumbolia Public License"))))
+
+(define-public python2-ghp-import
+ (package-with-python2
+ (strip-python2-variant python-ghp-import)))
+
(define-public shflags
(package
(name "shflags")
d=4375dcf36c21f748a5118c6f3faf1e14450e1e7b'>gnu: complexity: Update to 1.3....Ludovic Courtès 2015-09-26gnu: global: Update to 6.5.1....Andreas Enge 2015-08-29gnu: Use 'install-file' instead of 'mkdir-p' and 'copy-file' in obvious cases....Ludovic Courtès 2015-07-18gnu packages: Clean up synopses and descriptions....Alex Kost 2015-06-29gnu: withershins: Use new "libiberty" package....Ricardo Wurmus 2015-06-29gnu: global: Update to 6.5....Ludovic Courtès 2015-06-12gnu: Add withershins....Ricardo Wurmus