aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python-xyz.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 10d920b4b6..7f368d1ebc 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -13370,6 +13370,12 @@ Python style, together with a fast and comfortable execution environment.")
(string-append
"tibanna_args.command = command.replace('"
#$output "/bin/snakemake', 'python3 -m snakemake')")))))
+ ;; No longer needed with 7.15.2+
+ (add-after 'unpack 'tabulate-compatibility
+ (lambda _
+ (substitute* "snakemake/dag.py"
+ (("\"job\": rule,")
+ "\"job\": rule.name,"))))
(add-after 'unpack 'patch-version
(lambda _
(substitute* "setup.py"