aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/make-bootstrap.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/make-bootstrap.scm b/gnu/packages/make-bootstrap.scm
index 708cb39bb2..c79bcc2cf3 100644
--- a/gnu/packages/make-bootstrap.scm
+++ b/gnu/packages/make-bootstrap.scm
@@ -429,6 +429,7 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
(let* ((out (assoc-ref %outputs "out"))
(bindir (string-append out "/bin"))
(libdir (string-append out "/lib"))
+ (includedir (string-append out "/include"))
(libexecdir (string-append out "/libexec"))
(gcc (assoc-ref %build-inputs "gcc")))
(copy-recursively (string-append gcc "/bin") bindir)
@@ -444,6 +445,11 @@ for `sh' in $PATH, and without nscd, and with static NSS modules."
libexecdir)
(for-each remove-store-references
(find-files libexecdir ".*"))
+
+ ;; Starting from GCC 4.8, helper programs built natively
+ ;; (‘genchecksum’, ‘gcc-nm’, etc.) rely on C++ headers.
+ (copy-recursively (string-append gcc "/include/c++")
+ (string-append includedir "/c++"))
#t))))
(inputs `(("gcc" ,%gcc-static)))))
-avail'>...Ludovic Courtès 2021-03-19build-self: Silent Guile warnings while computing the derivation....Ludovic Courtès 2021-03-10ci: Remove hydra support....Mathieu Othacehe 2021-02-04channels: Record 'guix' channel metadata in (guix config)....Ludovic Courtès 2021-02-02build: Add a --show-duration option to the SCM test-driver....Maxim Cournoyer 2021-02-01guix package: Add '--export-channels'....Ludovic Courtès 2021-01-31build: test-driver.scm: Allow running as a standalone script....Maxim Cournoyer 2021-01-31build: test-driver.scm: Add a new '--errors-only' option....Maxim Cournoyer 2021-01-31build: test-driver.scm: Add test cases filtering options....Maxim Cournoyer 2021-01-31build: test-driver.scm: Enable colored test results by default....Maxim Cournoyer 2021-01-31build: test-driver.scm: Make output redirection optional....Maxim Cournoyer