aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cpp.scm58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnu/packages/cpp.scm b/gnu/packages/cpp.scm
index 22d1341b8d..2a00d3838a 100644
--- a/gnu/packages/cpp.scm
+++ b/gnu/packages/cpp.scm
@@ -63,6 +63,7 @@
#:use-module (gnu packages llvm)
#:use-module (gnu packages logging)
#:use-module (gnu packages maths)
+ #:use-module (gnu packages onc-rpc)
#:use-module (gnu packages perl)
#:use-module (gnu packages pkg-config)
#:use-module (gnu packages popt)
@@ -1153,3 +1154,60 @@ options that your program supports, their types, default values, and
documentation.")
(home-page "https://codesynthesis.com/projects/cli/")
(license license:expat)))
+
+(define-public xsd
+ (package
+ (name "xsd")
+ (version "4.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://www.codesynthesis.com/download/"
+ "xsd/" (version-major+minor version)
+ "/xsd-" version ".tar.bz2"))
+ (sha256
+ (base32 "1hi9ppxd34np8ydv1h0vgc2qpdmgcd1cdzgk30aidv670xjg91fx"))))
+ (build-system gnu-build-system)
+ (outputs '("out" "doc")) ;3.8 MiB of doc and examples
+ (arguments
+ `(#:test-target "test"
+ #:make-flags (list (string-append "--include-dir="
+ (assoc-ref %build-inputs "build")
+ "/include/")
+ (string-append "install_prefix="
+ (assoc-ref %outputs "out")))
+ #:phases (modify-phases %standard-phases
+ (add-after 'install 'move-doc
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let ((out (assoc-ref outputs "out"))
+ (doc (assoc-ref outputs "doc")))
+ (mkdir-p (string-append doc "/share/doc"))
+ (rename-file (string-append out "/share/doc/xsd")
+ (string-append doc "/share/doc/xsd-"
+ ,version)))))
+ (delete 'configure))))
+ (native-inputs
+ `(("build" ,build)
+ ("cli" ,cli)))
+ (inputs
+ `(("libcutl" ,libcutl)
+ ("libnsl" ,libnsl)
+ ("libxsd-frontend" ,libxsd-frontend)))
+ (propagated-inputs
+ ;; The code XSD generates requires the following library at run time;
+ ;; propagate it for convenience.
+ `(("xerces-c" ,xerces-c)))
+ (synopsis "XML Data Binding for C++")
+ (description "CodeSynthesis XSD (also known as libxsd or xsdcxx) is an XML
+Schema to C++ data binding compiler. Provided with an XML instance
+specification (XML Schema), it generates C++ classes that represent the given
+vocabulary as well as XML parsing and serialization code. The data stored in
+XML can then be accessed using types and functions that semantically
+correspond to an application domain rather than dealing with the intricacies
+of reading and writing XML.")
+ (home-page "https://codesynthesis.com/projects/xsd/")
+ ;; Exceptions are made to allow using the generated source files as well
+ ;; as the libxsd library in free software projects whose license is
+ ;; incompatible with the GPL v2. Refer to the file named FLOSSE for the
+ ;; details.
+ (license license:gpl2+)))
ring->btrfs-uuid....Danny Milosavljevic 2017-06-09file-systems: Provide string->iso9660-uuid....Danny Milosavljevic 2017-06-07file-systems: Use creation time if modification time is unset for ISO9660....Danny Milosavljevic 2017-06-03file-systems: Improve error handling in the iso9660 case - fixes boot problem....Danny Milosavljevic 2017-05-31file-systems: Improve error reporting....Danny Milosavljevic 2017-05-31gnu: build: Improve comments....Danny Milosavljevic 2017-05-27gnu: build: Improve docstrings....Danny Milosavljevic 2017-05-03gnu: build: file-systems: Add ISO-9660....Danny Milosavljevic 2017-04-13file-systems: Allow for bind-mounts of named sockets....Ludovic Courtès 2017-04-11build: Fix compilation warnings....Mathieu Othacehe 2017-03-01file-systems: Add FAT32 support....David Craven 2017-01-31file-systems: Do not read superblocks past the end of a device....Ludovic Courtès 2017-01-10system: Add btrfs file system support....David Craven 2017-01-10file-systems: Refactor file-system predicates....David Craven 2017-01-10file-systems: Refactor check-file-system....David Craven 2017-01-06file-systems: Refactor file system detection logic....David Craven 2016-11-29gnu: Allow nfs file systems to be automatically mounted....John Darrington 2016-11-06gnu: build: file-system: Change url of LUKS specification....ng0 2016-10-27file-systems: 'disk-partitions' detected partitions from mapped devices....Ludovic Courtès