aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index ac9e02a6f6..3fe593a01c 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -2014,7 +2014,7 @@ delivery.")
(("(CONFIGURE_FILE=).*" all var)
(string-append var out "/etc/exim.conf\n"))
(("(EXIM_USER=).*" all var)
- (string-append var "nobody\n"))
+ (string-append var "ref:exim\n"))
(("(FIXED_NEVER_USERS=).*" all var)
(string-append var "\n")) ; no root in build environment
(("(COMPRESS_COMMAND=).*" all var)
@@ -2031,6 +2031,13 @@ delivery.")
(("# (AUTH_PLAINTEXT=yes)" all line) line)
(("# (AUTH_SPA=yes)" all line) line)
(("# (AUTH_TLS=yes)" all line) line))
+ ;; The installation script calls Exim once to get its
+ ;; version number. Exim then fails to find the `exim`
+ ;; user and exits with non-zero status.
+ (substitute* "scripts/exim_install"
+ (("(\\$exim 2>/dev/null)" all var)
+ (string-append
+ "printf 'Exim version " #$version " #1'")))
;; This file has hard-coded relative file names for tools
;; despite the zcat configuration above.
(substitute* "src/exigrep.src"
pan>.dir-locals.el: Don't mess up indentation of prepend and append....Liliana Marie Prikler 2021-08-12Merge branch 'master' into core-updates-frozen...Marius Bakke 2021-08-02.dir-locals.el: Specify indentation rule for with-shepherd-action....Maxim Cournoyer 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-11packages: Add 'modify-inputs'....Ludovic Courtès 2021-06-29pack: Add support for the deb format....Maxim Cournoyer 2021-03-30build-system: Rewrite using gexps....Ludovic Courtès 2020-12-15system: 'init' does not recompute the hash of each store item....Ludovic Courtès 2020-11-17Merge remote-tracking branch 'origin/version-1.2.0' into master...Maxim Cournoyer 2020-11-16.dir-locals.el: Add upstream report link....Miguel Ángel Arruga Vivas 2020-11-16.dir-locals.el: Use setq-local on guix-directory....Christopher Lemmer Webber 2020-11-16.dir-locals.el: Prevent errors if .dir-locals.el isn't found....Christopher Lemmer Webber 2020-11-12maint: update-guix-package: Optionally add sources to store....Maxim Cournoyer 2020-11-01.dir-locals.el: Require cl-lib at runtime....Miguel Ángel Arruga Vivas 2020-10-31.dir-locals.el: Automatically set the GEISER-GUILE-LOAD-PATH variable....Maxim Cournoyer 2020-10-19maint: update-guix-package: Prevent accidentally breaking guix pull....Maxim Cournoyer