aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/qt.scm129
1 files changed, 129 insertions, 0 deletions
diff --git a/gnu/packages/qt.scm b/gnu/packages/qt.scm
index 2e44a6256a..7694334a2c 100644
--- a/gnu/packages/qt.scm
+++ b/gnu/packages/qt.scm
@@ -64,15 +64,18 @@
#:use-module (gnu packages check)
#:use-module (gnu packages cmake)
#:use-module (gnu packages compression)
+ #:use-module (gnu packages cpp)
#:use-module (gnu packages cups)
#:use-module (gnu packages curl)
#:use-module (gnu packages databases)
#:use-module (gnu packages documentation)
+ #:use-module (gnu packages elf)
#:use-module (gnu packages enchant)
#:use-module (gnu packages fontutils)
#:use-module (gnu packages flex)
#:use-module (gnu packages freedesktop)
#:use-module (gnu packages gcc)
+ #:use-module (gnu packages gdb)
#:use-module (gnu packages ghostscript)
#:use-module (gnu packages gl)
#:use-module (gnu packages glib)
@@ -4601,6 +4604,132 @@ warnings, ranging from unneeded memory allocations to misuses of the API,
including @i{fix-its} for automatic refactoring.")
(license license:lgpl2.0+)))
+(define-public qt-creator
+ (package
+ (name "qt-creator")
+ (version "9.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append
+ "https://download.qt.io/official_releases/qtcreator/"
+ (version-major+minor version) "/" version
+ "/qt-creator-opensource-src-" version ".tar.gz"))
+ (modules '((guix build utils)))
+ (snippet '(begin
+ (for-each
+ delete-file-recursively
+ ;; Remove bundled libraries, where supported.
+ ;; TODO: package and unbundle litehtml
+ '("src/libs/3rdparty/yaml-cpp"
+ "src/shared/qbs/src/shared/qtscript/src/3rdparty"
+ "tests/unit/unittest/3rdparty"
+ ;; Marketplace recommends nonfree extensions;
+ ;; remove it.
+ "src/plugins/marketplace"))
+ (substitute* "src/plugins/CMakeLists.txt"
+ (("add_subdirectory\\(marketplace).*") ""))
+ (substitute* "src/plugins/plugins.qbs"
+ ((".*marketplace/marketplace.qbs.*") ""))))
+ (sha256
+ (base32
+ "1adyxs0cnqx14gwzkvh909c52449ia6y87n1r4qf6wwydhch43cs"))))
+ (build-system qt-build-system)
+ (arguments
+ (list
+ #:qtbase qtbase
+ #:configure-flags
+ #~(list "-DWITH_DOCS=ON"
+ "-DBUILD_DEVELOPER_DOCS=ON"
+ "-DCMAKE_VERBOSE_MAKEFILE=ON"
+ "-DWITH_TESTS=ON"
+ ;; Extend the RUNPATH with lib/qtcreator, which contains
+ ;; multiple shared objects.
+ (string-append "-DCMAKE_SHARED_LINKER_FLAGS=-Wl,-rpath="
+ #$output "/lib/qtcreator"))
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-build
+ (lambda _
+ ;; Add a missing link directive (see:
+ ;; https://bugreports.qt.io/browse/QTCREATORBUG-28434).
+ (substitute* "src/libs/tracing/CMakeLists.txt"
+ (("DEPENDS Utils Qt5::Qml Qt5::Quick")
+ "DEPENDS Utils Qt5::Quick")
+ (("PUBLIC_DEPENDS Qt5::Widgets")
+ "PUBLIC_DEPENDS Qt5::Widgets Qt5::Qml"))))
+ (add-after 'unpack 'patch-paths
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* '("src/libs/utils/commandline.cpp"
+ "src/libs/utils/deviceshell.cpp")
+ (("/bin/sh")
+ (search-input-file inputs "bin/sh")))
+ (substitute* "src/libs/utils/qtcprocess.cpp"
+ (("/usr/bin/env")
+ (search-input-file inputs "bin/env")))
+ (substitute* "tests/auto/utils/qtcprocess/tst_qtcprocess.cpp"
+ (("/bin/sh")
+ (which "sh")))))
+ (add-before 'build 'build-doc
+ (lambda _
+ (invoke "cmake" "--build" "." "--target=docs" "-v")))
+ (add-after 'build-doc 'install-doc
+ (lambda _
+ (invoke "cmake" "--install" "." "--prefix" #$output
+ "--component=qch_docs")
+ (invoke "cmake" "--install" "." "--prefix" #$output
+ "--component=html_docs")))
+ (replace 'check
+ ;; Loosely based on .github/workflows/build_cmake.yml.
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests?
+ (invoke "xvfb-run" ;for the 'renderpass' tests
+ "ctest" "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1")
+ "--label-exclude" "exclude_from_precheck"
+ "--exclude-regex" "tst_perfdata"))))
+ (add-after 'qt-wrap 'wrap-bin
+ ;; Make a few well-integrated tools readily available.
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (wrap-program (search-input-file outputs "bin/qtcreator")
+ `("PATH" suffix ,(map (lambda (c)
+ (dirname (search-input-file inputs c)))
+ '("bin/clang-tidy"
+ "bin/clazy-standalone"
+ "bin/gdb"
+ "bin/valgrind")))))))))
+ (native-inputs
+ (list googletest
+ pkg-config
+ python
+ qttools
+ qttranslations
+ vulkan-headers
+ xvfb-run))
+ (inputs
+ (list bash-minimal
+ coreutils-minimal
+ clang
+ clazy
+ elfutils
+ gdb
+ libxkbcommon
+ llvm
+ qt5compat
+ qtdeclarative
+ qtshadertools
+ qtsvg
+ yaml-cpp
+ valgrind
+ vulkan-loader
+ `(,zstd "lib")))
+ (home-page "https://www.qt.io/")
+ (synopsis "Integrated development environment (IDE) for Qt")
+ (description "Qt Creator is an IDE tailored to the needs of Qt developers.
+It includes features such as an advanced code editor, a visual debugger and a
+@acronym{GUI, Graphical User Interface} designer.")
+ (license license:gpl3+))) ;with the Qt Company GPL Exception 1.0
+
;;;
;;; Avoid adding new packages to the end of this file. To reduce the chances
;;; of a merge conflict, place them above by existing packages with similar
ix/commit/gnu/system/examples?id=7194745a16008947f6cf1a3aba0f86e8ca18c2f6'>services: Use guix-service-type....* gnu/services/base.scm (%base-services): Replace guix-service with guix-service-type. * gnu/system/examples/docker-image.tmpl (services): Same. Efraim Flashner 2018-12-24doc: Example vm-image doesn't need firmware....* gnu/system/examples/vm-image.tmpl (firmware): New field, explicitly empty list. Efraim Flashner 2018-12-03doc: Fix "desktop" OS config example....* gnu/system/examples/desktop.tmpl (file-systems): Add 'file-system-label' call in 'device' field. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Laura Lazzati 2018-11-26services: openssh: Install OpenSSH in the system profile....This ensures one can scp to or from the GuixSD machine that uses the service. * gnu/services/ssh.scm (openssh-service-type)[extensions]: Add PROFILE-SERVICE-TYPE extension. * gnu/system/examples/bare-bones.tmpl <packages>: Remove OPENSSH. * doc/guix.texi (Using the Configuration System): Adjust accordingly. Ludovic Courtès 2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....* gnu/services/networking.scm (dhcp-client-service-type): Add default value. * gnu/system/examples/bare-bones.tmpl: Use (service dhcp-client-service-type) instead of (dhcp-client-service). * gnu/system/examples/beaglebone-black.tmpl: Likewise. * gnu/tests/base.scm (%avahi-os): Likewise. * gnu/tests/databases.scm (%memcached-os): Likewise. (%mongodb-os): Likewise. * gnu/tests/dict.scm (%dicod-os): Likewise. * gnu/tests/mail.scm (%opensmtpd-os): Likewise. (%exim-os): Likewise. (%dovecot-os): Likewise. * gnu/tests/messaging.scm (run-xmpp-test): Likewise. (run-bitlbee-test): Likewise. * gnu/tests/monitoring.scm (%prometheus-node-exporter-os): Likewise. * gnu/tests/networking.scm (%inetd-os): Likewise. (run-iptables-test): Likewise. * gnu/tests/nfs.scm (%base-os): Likewise. * gnu/tests/rsync.scm (%rsync-os): Likewise. * gnu/tests/ssh.scm (run-ssh-test): Likewise. * gnu/tests/version-control.scm (%cgit-os): Likewise. (%git-http-os): Likewise. (%gitolite-os): Likewise. * gnu/tests/virtualization.scm (%libvirt-os): Likewise. * gnu/tests/web.scm (%httpd-os): Likewise. (%nginx-os): Likewise. (%varnish-os): Likewise. (%php-fpm-os): Likewise. (%hpcguix-web-os): Likewise. (%tailon-os): Likewise. * tests/guix-system.sh: Likewise. * doc/guix.texi (Networking Services): Document 'dhcp-client-service-type' and remove 'dhcp-client-service'. Ludovic Courtès 2018-07-05doc: Improve UEFI/BIOS bootloader documentation....Partly fixes <https://bugs.gnu.org/30312>. * doc/guix.texi (Preparing for Installation): Add note on how to choose between UEFI and BIOS. (Using the Configuration System)[Bootloader]: New subsubsection. (Bootloader Configuration): Expound on the bootloader type and target. * gnu/system/examples/desktop.tmpl: Switch to UEFI. * gnu/system/examples/bare-bones.tmpl: Explicitly mention "legacy" and "BIOS" in the comments. Ludovic Courtès 2018-05-28file-systems: Remove 'title' field and add <file-system-label>....The 'title' field was easily overlooked and was an endless source of confusion. Now, the value of the 'device' field is self-contained. * gnu/system/file-systems.scm (<file-system>): Change constructor name to '%file-system'. [title]: Remove. (<file-system-label>): New record type with printer. (report-deprecation, device-expression) (process-file-system-declaration, file-system): New macros. (file-system-title): New procedure. (file-system->spec, spec->file-system): Adjust to handle <file-system-label>. * gnu/system.scm (bootable-kernel-arguments): Add case for 'file-system-label?'. (read-boot-parameters): Likewise. (mapped-device-user): Avoid 'file-system-title'. (fs->boot-device): Remove. (operating-system-boot-parameters): Use 'file-system-device' instead of 'fs->boot-device'. (device->sexp): Add case for 'file-system-label?'. * gnu/bootloader/grub.scm (grub-root-search): Add case for 'file-system-label?'. * gnu/system/examples/bare-bones.tmpl, gnu/system/examples/beaglebone-black.tmpl, gnu/system/examples/lightweight-desktop.tmpl, gnu/system/examples/vm-image.tmpl: Remove uses of 'title'. * gnu/system/vm.scm (virtualized-operating-system): Remove uses of 'file-system-title'. * guix/scripts/system.scm (check-file-system-availability): Likewise, and adjust fix-it hint. (check-initrd-modules)[file-system-/dev]: Likewise. * gnu/build/file-systems.scm (canonicalize-device-spec): Remove 'title' parameter. [canonical-title]: Remove. Match on SPEC's type rather than on CANONICAL-TITLE. (mount-file-system): Adjust caller. * gnu/build/linux-boot.scm (boot-system): Interpret ROOT here. * gnu/services/base.scm (file-system->fstab-entry): Remove use of 'file-system-title'. * doc/guix.texi (File Systems): Remove documentation of the 'title' field. Rewrite documentation of 'device' and document 'file-system-label'. Ludovic Courtès 2018-03-24system: Add "guix system docker-image" command....* gnu/system/vm.scm (system-docker-image): New procedure. * guix/scripts/system.scm (system-derivation-for-action): Add a case for docker-image, and in that case, call system-docker-image. (show-help): Document docker-image. (guix-system): Parse arguments for docker-image. * doc/guix.texi (Invoking guix system): Document "guix system docker-image". * gnu/system/examples/docker-image.tmpl: New file. Chris Marusich 2018-03-03system: beaglebone-black: Use 'initrd-modules'....* gnu/system/examples/beaglebone-black.tmpl: Use 'initrd-modules' instead of 'initrd'. Ludovic Courtès 2018-01-21doc: No longer mention Wicd in OS examples....* gnu/system/examples/desktop.tmpl, gnu/system/examples/lightweight-desktop.tmpl: Mention NetworkManager instead of Wicd. Ludovic Courtès 2017-12-22system: examples: Add missing initrd to beaglebone-black.tmpl....* gnu/system/examples/beaglebone-black.tmpl (operating-system): Add the initrd with "omap_hsmmc" as an extra-module. Mathieu Othacehe 2017-12-18system: examples: Add a template for BeagleBone Black....* gnu/system/examples/beaglebone-black.tmpl: New file. * Makefile.am (EXAMPLES): Add it. * gnu/system/install.scm (/etc/configuration-files): Add it. Mathieu Othacehe 2017-12-06gnu, doc, tests: Use ‘bootloader-configuration’ everywhere....* doc/guix.texi (Proceeding with the Installation): Replace the old-style ‘grub-configuration’ with the newer ‘bootloader-configuration’ syntax. * gnu/system/examples/vm-image.tmpl: Likewise. * gnu/system/install.scm (installation-os): Likewise. * gnu/tests.scm (%simple-os): Likewise. * gnu/tests/install.scm (%minimal-os, %minimal-os-on-vda, %separate-home-os) (%separate-store-os, %raid-root-os, %encrypted-root-os, %btrfs-root-os): Likewise. * gnu/tests/nfs.scm (%base-os): Likewise. * tests/guix-system.scm (OS_BASE, make_user_config): Likewise. * tests/system.scm (%os, %os-with-mapped-device): Likewise. Tobias Geerinckx-Rice 2017-10-11doc: Give an example with a FAT UUID....* gnu/system/examples/lightweight-desktop.tmpl <file-systems>: Add a UUID for the /boot/efi partition. * doc/guix.texi (Using the Configuration System): Mention it. Ludovic Courtès 2017-09-12doc: Use Screen and OpenSSH in the bare-bones example....* gnu/system/examples/bare-bones.tmpl (packages): Remove TCPDUMP; add SCREEN and OPENSSH. * doc/guix.texi (Using the Configuration System): Adjust explanation accordingly. Ludovic Courtès 2017-08-23gnu: bootloader: Deprecate "device" field in favor of "target"....* gnu/bootloader.scm (<bootloader-configuration>): Deprecate "device" field in favor of "target" field. This is mostly a renaming but also a generalization to support UEFI targets being paths to a mounted partition instead of a device name. * gnu/system/examples/bare-bones.tmpl: * gnu/system/examples/desktop.tmpl: * gnu/system/examples/lightweight-desktop.tmpl: * gnu/system/examples/vm-image.tmpl: * gnu/system/install.scm: * gnu/tests.scm: * gnu/tests/install.scm: * gnu/tests/nfs.scm: * tests/system.scm: Adapt all invocations of bootloader-configuration. * guix/scripts/system.scm (perform-action): Rename device argument to bootloader-target. (process-action): Adapt caller. * doc/guix.texi (Proceeding with the Installation): * doc/guix.texi (Bootloader Configuration): Update documentation. Andy Wingo 2017-08-20gnu: grub-efi-bootloader: Specialize grub-install invocation....* gnu/bootloader/grub.scm (install-grub-efi): Fix grub-install invocation for EFI systems. * gnu/system/examples/bare-bones.tmpl: Use the newer "bootloader-configuration" syntax. * gnu/system/examples/desktop.tmpl: Use bootloader-configuration sytax. Also, use the same label for the LUKS-mapped device and the root partition. Remove unneeded "title" field for the file-system based on LUKS; as noted in the manual, the "title" field is ignored for mapped devices. * gnu/system/examples/lightweight-desktop.tmpl: Use bootloader-configuration, and use grub-efi-bootloader. Andy Wingo 2017-05-19doc: Update for UEFI systems....* doc/guix.texi (USB Stick Installation): Mention UEFI. (Preparing for Installation): Add notes about EFI System Partition, and mounting partitions before init. (Proceeding with the Installation): Mention the GRUB-EFI package. (Using the Configuration System): Lightweight desktop is now a UEFI system. (GRUB Configuration): Expand on package field. Add indexes. * gnu/system/examples/lightweight-desktop.tmpl: Adjust to native EFI configuration. Marius Bakke 2017-05-17maint: The 'release' target builds a VM image....* gnu/system/examples/vm-image.tmpl: New file. * Makefile.am (GUIXSD_VM_SYSTEMS, GUIXSD_VM_IMAGE_BASE, GUIXSD_VM_IMAGE_SIZE): New variables. (release): Add logic to build a VM image. (EXAMPLES): Add 'gnu/system/examples/vm-image.tmpl'. * doc/guix.texi (Running GuixSD in a VM, Installing GuixSD in a VM): Mention the pre-built VM image. Leo Famulari 2017-04-12doc: Use OpenSSH instead of lsh in bare-bones template....* gnu/system/examples/bare-bones.tmpl (services): Use openssh-service-type instead of lsh-service. Leo Famulari 2017-02-23gnu: lightweight-desktop.tmpl: Remove xmonad....* gnu/system/examples/lightweight-desktop.tmpl (packages): Remove xmonad. Leo Famulari 2017-02-23gnu: lightweight-desktop.tmpl: Complete i3-wm....* gnu/system/examples/lightweight-desktop.tmpl (packages): Add i3status and dmenu. (use-package-modules): Add suckless. Leo Famulari 2017-02-13system: Use the normalized codeset for the locale name in the examples....* gnu/system/examples/bare-bones.tmpl <locale>: Change to "en_US.utf8". * gnu/system/examples/desktop.tmpl <locale>: Likewise. * gnu/system/examples/lightweight-desktop.tmpl <locale>: Likewise. Ludovic Courtès 2016-11-28doc: Suggest installing gvfs....* gnu/system/examples/desktop.tmpl: Add gvfs to the system-wide list of packages. Ricardo Wurmus 2016-11-24doc: Document encrypted root partitions....This is a followup to f7f292d359e0eb77617f4ecf6b3164f868ec1784. * doc/guix.texi (Preparing for Installation): Give commands for encrypted root installation. (Proceeding with the Installation): Add item about mapped devices. (File Systems): Mention that 'dependencies' can list <mapped-device> objects. * gnu/system/examples/desktop.tmpl (mapped-devices): New field. (file-systems): Add 'dependencies' field. Ludovic Courtès