aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/syncthing.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/syncthing.scm b/gnu/packages/syncthing.scm
index 904f32fc52..075836791f 100644
--- a/gnu/packages/syncthing.scm
+++ b/gnu/packages/syncthing.scm
@@ -1980,3 +1980,30 @@ bounds.")
data serialization format.")
(home-page "https://github.com/golang/protobuf")
(license bsd-3))))
+
+(define-public go-github-com-prometheus-client-model-go
+ (let ((commit "99fa1f4be8e564e8a6b613da7fa6f46c9edafc6c")
+ (revision "0"))
+ (package
+ (name "go-github-com-prometheus-client-model-go")
+ (version (git-version "0.0.2" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/prometheus/client_model.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "19y4ywsivhpxj7ikf2j0gm9k3cmyw37qcbfi78n526jxcc7kw998"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/prometheus/client_model/go"
+ #:unpack-path "github.com/prometheus/client_model"))
+ (propagated-inputs
+ `(("go-github-com-golang-protobuf-proto"
+ ,go-github-com-golang-protobuf-proto)))
+ (synopsis "Data model artifacts for Prometheus")
+ (description "This package provides data model artifacts for Prometheus.")
+ (home-page "https://github.com/prometheus/client_model")
+ (license asl2.0))))
urce
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "conv" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "168j1npqrif1yqxbgbk0pdrx9shzhs5ylc5a4xw49b6hbxi11zvq"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t ; Package needs 'unicode' crate.
+ #:cargo-inputs
+ (("rust-custom-derive" ,rust-custom-derive-0.1))
+ #:cargo-development-inputs
+ (("rust-quickcheck" ,rust-quickcheck-0.2)
+ ("rust-winapi" ,rust-winapi-0.2))))
+ (home-page "https://github.com/DanielKeep/rust-conv")
+ (synopsis "Conversion traits with more specific semantics")
+ (description
+ "This crate provides a number of conversion traits with more specific
+semantics than those provided by @code{as} or @code{From}/@code{Into}.")
+ (license license:expat)))
+
(define-public rust-core-arch-0.1
(package
(name "rust-core-arch")