aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 27deaebdb8..4cda7192fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -13399,3 +13399,44 @@ MacFUSE. The binding is created using the standard @code{ctypes} library.")
(define-public python2-fusepy
(package-with-python2 python-fusepy))
+
+(define-public python2-gdrivefs
+ (package
+ (name "python2-gdrivefs")
+ (version "0.14.9")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "gdrivefs" version))
+ (sha256
+ (base32
+ "0v9sp2cfg4ki3wagkwf3rnfpjhvgf845anz3757il9z95yvvcvb7"))))
+ (build-system python-build-system)
+ (arguments
+ `(#:python ,python-2
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'build 'patch-setup-py
+ (lambda _
+ ;; Update requirements from dependency==version
+ ;; to dependency>=version
+ (substitute* "gdrivefs/resources/requirements.txt"
+ (("==") ">="))
+ #t)))))
+ (native-inputs
+ `(("python2-gipc" ,python2-gipc)
+ ("python2-gevent" ,python2-gevent)
+ ("python2-greenlet" ,python2-greenlet)
+ ("python2-httplib2" ,python2-httplib2)
+ ("python2-uritemplate" ,python2-uritemplate)
+ ("python2-oauth2client" ,python2-oauth2client)
+ ("python2-six" ,python2-six)))
+ (propagated-inputs
+ `(("python2-dateutil" ,python2-dateutil)
+ ("python2-fusepy" ,python2-fusepy)
+ ("python2-google-api-client" ,python2-google-api-client)))
+ (home-page "https://github.com/dsoprea/GDriveFS")
+ (synopsis "Mount Google Drive as a local file system")
+ (description "@code{gdrivefs} provides a FUSE wrapper for Google Drive
+under Python 2.7.")
+ (license license:gpl2)))
" and "volatile-root?" arguments. (perform-action): Ditto. (process-action): Construct the <image> record and pass it to "perform-action" procedure. * tests/guix-system.sh: Adapt accordingly. * gnu/system/images/hurd.scm: Return the default image. * gnu/system/images/novena.scm: Ditto. * gnu/system/images/pine64.scm: Ditto. * gnu/system/images/pinebook-pro.scm Ditto. Mathieu Othacehe 2021-02-17scripts: system: Remove 'vm-image' command....Remove the 'vm-image' command that has been superseded by the 'image' command. * gnu/system/vm.scm (system-qemu-image): Remove it. * guix/scripts/system.scm (system-derivation-for-action): Mark 'vm-image' command as deprecated and use the image API to produce the VM image. (perform-action, show-help): Adapt accordingly. * tests/guix-system.sh: Ditto. * doc/guix.texi (Invoking guix system, Running Guix in a VM): Ditto. * etc/completion/fish/guix.fish: Ditto. * etc/completion/zsh/_guix: Ditto. Mathieu Othacehe 2021-01-30guix system: Test 'extension-graph' and 'shepherd-graph'....* tests/guix-system.sh: Test 'guix system extension-graph' and 'guix system shepherd-graph'. Ludovic Courtès 2021-01-19system: Rename 'disk-image' command 'image'....* guix/scripts/system.scm (system-derivation-for-action): Rename 'disk-image' command 'image'. Warn when using the now deprecated 'disk-image' command. (show-help): Adapt accordingly. (guix-system): Ditto. * tests/guix-system.sh: Ditto. * gnu/system/examples/bare-hurd.tmpl: Ditto. * doc/guix.texi (Building the Installation Image, Building the Installation Image for ARM Boards, Invoking guix pack, Invoking guix system): Adapt documentation. Mathieu Othacehe 2021-01-13services: shepherd: 'shepherd-service-type' requires documentation....* gnu/services/shepherd.scm (shepherd-service-type): Require a 'description' form. * gnu/services/base.scm (root-file-system-service-type) (rngd-service-type, host-name-service-type): (virtual-terminal-service-type, console-keymap-service-type) (syslog-service-type, swap-service-type) (kmscon-service-type): Add description. * gnu/services/networking.scm (dhcp-client-service-type): Likewise. * gnu/system/install.scm (cow-store-service-type): Likewise. * gnu/system/linux-container.scm (dummy-networking-service-type): Likewise. * gnu/system/mapped-devices.scm (device-mapping-service-type): Likewise. * tests/guix-system.sh: Likewise. Ludovic Courtès