aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm40
1 files changed, 40 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 94a5377c46..cee78656cb 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -8767,3 +8767,43 @@ support for JSON Schema Draft 3, JSON Schema Draft 2, and JSON Schema Draft 1
is also included.")
(home-page "https://github.com/ruby-json-schema/json-schema")
(license license:expat)))
+
+(define-public swagger-diff
+ (package
+ (name "swagger-diff")
+ (version "1.1.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "swagger-diff" version))
+ (sha256
+ (base32
+ "1hxx50nga1bqn254iqjcdwkc9c72364ks9lyjyw10ajz0l0ly7sn"))))
+ (build-system ruby-build-system)
+ (arguments
+ `(#:test-target "spec"
+ #:phases
+ (modify-phases %standard-phases
+ ;; Don't run or require rubocop, the code linting tool, as this is a
+ ;; bit unnecessary.
+ (add-after 'unpack 'dont-run-rubocop
+ (lambda _
+ (substitute* "Rakefile"
+ ((".*rubocop.*") "")
+ ((".*RuboCop.*") ""))
+ #t)))))
+ (propagated-inputs
+ `(("ruby-json-schema" ,ruby-json-schema)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec-core" ,ruby-rspec-core)
+ ("ruby-rspec-expectations" ,ruby-rspec-expectations)))
+ (synopsis
+ "Compare Open API Initiative specification files")
+ (description
+ "Swagger::Diff is a utility for comparing two different Open API
+Initiative (OAI) specifications (formerly known as Swagger specifications).
+It is intended to determine whether a newer API specification is
+backwards-compatible with an older API specification.")
+ (home-page "https://github.com/civisanalytics/swagger-diff")
+ (license license:bsd-3)))
nu/system.scm?id=7940188ebfb28fc36426924b16fdc8255a88acaf'>system: Fix typo in 'read-boot-parameters'....Ludovic Courtès 2017-09-11system: Serialize the UUID type in the "parameters" file....Ludovic Courtès 2017-09-11system: Introduce a disjoint UUID type....Ludovic Courtès 2017-08-01Merge branch 'master' into core-updatesMarius Bakke 2017-07-28bootloader: Use <menu-entry> for the bootloader side....Danny Milosavljevic 2017-07-23Merge branch 'master' into core-updatesLeo Famulari 2017-07-23gnu: Add support for aarch64's compiled kernel....Efraim Flashner 2017-07-23Merge branch 'master' into core-updatesLeo Famulari 2017-07-18system: Add 'newuidmap' and 'newgidmap' to %SETUID-PROGRAMS....宋文武 2017-07-17locale: Demonadify the locale creation API....Ludovic Courtès 2017-06-30system: Avoid collision between GMP variants in the global profile....Ludovic Courtès 2017-06-30Merge branch 'master' into core-updatesLudovic Courtès 2017-06-30system: Use "@" to refer to the 'shadow' package....Ludovic Courtès 2017-06-29Merge branch 'master' into core-updatesLeo Famulari 2017-06-29system: Add 'shadow' to %BASE-PACKAGES....Ludovic Courtès 2017-06-11Merge branch 'master' into core-updates...Marius Bakke 2017-06-10bootloader: Fix rebase error on f96752e commit....Mathieu Othacehe 2017-06-10bootloader: Rename boot-name to bootloader-name....Mathieu Othacehe 2017-06-10Merge branch 'master' into core-updatesMarius Bakke 2017-06-08bootloader: Use menu-entry to define custom bootloader entries....Mathieu Othacehe 2017-05-28gnu: Remove workaround for <https://bugs.gnu.org/26238>....Marius Bakke 2017-05-19system: Use Guile 2.2 rather than 2.0 in %BASE-PACKAGES....Ludovic Courtès 2017-05-16bootloader: Add bootloader name to boot-parameters record....Mathieu Othacehe 2017-05-16bootloader: Add extlinux support....Mathieu Othacehe