aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/lisp.scm11
1 files changed, 4 insertions, 7 deletions
diff --git a/gnu/packages/lisp.scm b/gnu/packages/lisp.scm
index 498eee9526..a2e0f0724d 100644
--- a/gnu/packages/lisp.scm
+++ b/gnu/packages/lisp.scm
@@ -800,7 +800,7 @@ enough to play the original mainframe Zork all the way through.")
(define-public txr
(package
(name "txr")
- (version "238")
+ (version "239")
(source
(origin
(method git-fetch)
@@ -809,15 +809,12 @@ enough to play the original mainframe Zork all the way through.")
(commit (string-append "txr-" version))))
(file-name (git-file-name name version))
(sha256
- (base32 "0asdq4n828xb1m31s7f47mqcbjqkzxz11bwnw8v3f2249m93ync4"))))
+ (base32 "1jldpkd5f855m3z4zjpd1ha64f405pcdwwrnr8jnk66v22dsvdwx"))))
(build-system gnu-build-system)
(arguments
`(#:configure-flags
- (let ((target ,(%current-target-system)))
- (list (string-append "cc=" (if target
- (string-append target "-gcc")
- "gcc"))
- (string-append "--prefix=" (assoc-ref %outputs "out"))))
+ (list ,(string-append "cc=" (cc-for-target))
+ (string-append "--prefix=" (assoc-ref %outputs "out")))
#:test-target "tests"
#:phases
(modify-phases %standard-phases
'2023-01-07 23:06:54 +0200'>2023-01-07gnu: gtkd: Fix pkgconfig directory.Efraim Flashner * gnu/packages/dlang.scm (gtkd)[arguments]: Add make-flag to set the pkgconfig directory correctly. 2023-01-02gnu: gtkd: Remove input labels.Efraim Flashner * gnu/packages/dlang.scm (gtkd)[native-inputs]: Remove input labels. 2023-01-02gnu: gtkd: Remove trailing #t from phases.Efraim Flashner * gnu/packages/dlang.scm (gtkd)[arguments]: Remove trailing #t from phases. 2023-01-02gnu: gtkd: Update to 3.10.0.Efraim Flashner * gnu/packages/dlang.scm (gtkd): Update to 3.10.0. [arguments]: Rename 'prepare-x phase to 'pre-check, set CC for the tests. 2023-01-02gnu: ldc: Update to 1.30.0.Efraim Flashner * gnu/packages/dlang.scm (ldc-bootstrap): Update to 1.30.0. [native-inputs]: Remove ld-gold-wrapper, Add lld-wrapper with lld-11. (ldc)[arguments]: Adjust 'fix-compiler-rt-library-discovery phase to change the order of linked libraries. Adjust 'disable-problematic-tests phase to work around more GDB tests. Adjust custom 'check phase for race condition in one of the tests. 2022-06-26gnu: ldc: Work towards building on aarch64-linux.Efraim Flashner * gnu/packages/dlang.scm (ldc)[arguments]: Adjust configure-flags to not dynamically compile. Adjust custom 'fix-compiler-rt-library-discovery phase to add a case for aarch64. Adjust custom'disable-problematic-tests phase to remove some tests for aarch64-linux. 2022-06-26gnu: ldc: Update skipped tests on i686-linux.Efraim Flashner * gnu/packages/dlang.scm (ldc)[arguments]: Adjust custom 'disable-problematic-tests phase to skip fewer tests. 2022-06-26gnu: Remove unneeded ldc bootstrap packages.Efraim Flashner * gnu/packages/dlang.scm (ldc-bootstrap-0.17, ldc-bootstrap-1.12, ldc-bootstrap-1.24): Remove packages. (ldc-bootstrap-1.27): Rename to ldc-bootstrap. Absorb inherited package adjustments. (ldc): Adjust to ldc-bootstrap-1.27 renaming. 2022-06-26gnu: ldc-bootstrap-1.27: Build with gdmd.Esther Flashner * gnu/packages/dlang.scm (ldc-bootstrap-1.27)[native-inputs]: Replace ldc-bootstrap-1.24 with gdmd. [supported-systems]: Mark all systems supported. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> 2022-06-26gnu: Add gdmd.Esther Flashner * gnu/packages/dlang.scm (gdmd): New variable. Co-authored-by: Efraim Flashner <efraim@flashner.co.il> 2022-06-26Revert "gnu: ldc-bootstrap-0.17: Add support for aarch64-linux."Efraim Flashner This reverts commit 4f6ed3d2f8531ce1b75dc79365ce67587d8cb7e1. While this does allow building ldc on aarch64, it isn't actually helpful. 2022-06-19gnu: dub: Use G-expressions.( * gnu/packages/dlang.scm (dub)[arguments]: Rewrite as G-expressions. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: dub: Update to 1.23.0.( This also fixes Dub's build, which was previously failing because of how ancient it was. * gnu/packages/dlang.scm (dub): Update to 1.23.0. [arguments]: Set target CC & LD environment variables. Invoke build.d. Don't explicitly return #t from phases. [native-inputs]: Add d-tools and ld-gold-wrapper. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: d-tools: Update to 2.100.0.( * gnu/packages/dlang.scm (d-tools): Update to 2.100.0. [arguments]: Adjust accordingly. Reinstate a custom 'check phase. Install the rdmd man page. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: d-tools: Don't use unstable tarball.( * gnu/packages/dlang.scm (d-tools)[source]: Use GIT-FETCH and GIT-FILE-NAME. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: d-tools: Use G-expressions.( * gnu/packages/dlang.scm (d-tools)[arguments]: Rewrite as G-expressions. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: d-tools: Fix build.( * gnu/packages/dlang.scm (d-tools)[arguments]: Set target CC and LD environment variables. [native-inputs]: Add ld-gold-wrapper. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-19gnu: rdmd: Rename to d-tools.( * gnu/packages/dlang.scm (rdmd): Rename this… (d-tools): …to this. [home-page, synopsis, description]: Update accordingly. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> 2022-06-23gnu: ldc-bootstrap-0.17: Add support for aarch64-linux.Efraim Flashner * gnu/packages/dlang.scm (ldc-bootstrap-0.17)[supported-systems]: Add aarch64-linux. [arguments]: When building targeting aarch64-linux build for armhf-linux.