aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm25
-rw-r--r--gnu/packages/golang.scm23
2 files changed, 25 insertions, 23 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 2ebb1251e0..1808ae154c 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -114,6 +114,31 @@
a human-readable byte format.")
(license license:asl2.0)))
+(define-public go-git-sr-ht-emersion-go-scfg
+ (package
+ (name "go-git-sr-ht-emersion-go-scfg")
+ (version "0.0.0-20211215104734-c2c7a15d6c99")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://git.sr.ht/~emersion/go-scfg")
+ (commit (go-version->git-ref version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "02gn8hz8zfv8y0krysx2wv951gw8hmhdfqf1ysidwm7i293365w4"))))
+ (build-system go-build-system)
+ (arguments
+ (list #:import-path "git.sr.ht/~emersion/go-scfg"))
+ (propagated-inputs
+ (list go-github-com-google-shlex
+ go-github-com-davecgh-go-spew))
+ (home-page "https://git.sr.ht/~emersion/go-scfg")
+ (synopsis "Go library for simple configuration file format")
+ (description
+ "Package go-scfg parses scfg files.")
+ (license license:expat)))
+
(define-public go-git-sr-ht-emersion-go-sqlite3-fts5
(package
(name "go-git-sr-ht-emersion-go-sqlite3-fts5")
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 310336ab31..aeb205571c 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9226,29 +9226,6 @@ kubernetes-sigs/yaml is a permanent fork of
"Colorstring provides functions for colorizing strings for terminal output.")
(license license:expat)))
-(define-public go-git-sr-ht-emersion-go-scfg
- (package
- (name "go-git-sr-ht-emersion-go-scfg")
- (version "0.0.0-20211215104734-c2c7a15d6c99")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://git.sr.ht/~emersion/go-scfg")
- (commit (go-version->git-ref version))))
- (file-name (git-file-name name version))
- (sha256
- (base32 "02gn8hz8zfv8y0krysx2wv951gw8hmhdfqf1ysidwm7i293365w4"))))
- (build-system go-build-system)
- (arguments (list #:import-path "git.sr.ht/~emersion/go-scfg"))
- (propagated-inputs
- (list go-github-com-google-shlex
- go-github-com-davecgh-go-spew))
- (home-page "https://git.sr.ht/~emersion/go-scfg")
- (synopsis "Go library for simple configuration file format")
- (description "Package go-scfg parses scfg files.")
- (license license:expat)))
-
(define-public go-github-com-google-go-jsonnet
(package
(name "go-github-com-google-go-jsonnet")