aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm17
1 files changed, 16 insertions, 1 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 9bdc8ee68d..836a3950f8 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -10464,13 +10464,28 @@ abbreviation of the mode line displays (lighters) of minor modes.")
(base32
"1b7mjjh0d6fmkkd9vyj64vca27xqhga0nvyrrcqxpqjn62zq046y"))))
(build-system emacs-build-system)
+ (native-inputs
+ `(("texinfo" ,texinfo)))
(propagated-inputs
`(("emacs-diminish" ,emacs-diminish)))
(arguments
`(#:tests? #t
#:test-command '("emacs" "--batch"
"-l" "use-package-tests.el"
- "-f" "ert-run-tests-batch-and-exit")))
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'install 'install-manual
+ (lambda* (#:key outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (info-dir (string-append out "/share/info")))
+ (mkdir-p info-dir)
+ (install-file "use-package.info" info-dir)
+ #t)))
+ (add-before 'install-manual 'build-manual
+ (lambda _
+ (invoke "makeinfo" "use-package.texi")
+ #t)))))
(home-page "https://github.com/jwiegley/use-package")
(synopsis "Declaration for simplifying your .emacs")
(description "The use-package macro allows you to isolate package
='/guix/commit/gnu/tests/base.scm?id=3302e03ba0edca49347c6a2b215e56bd53a6b113'>services: guix: Add 'set-http-proxy' action....Ludovic Courtès 2020-04-06services: syslog: Create log files as non-world-readable....Ludovic Courtès 2020-03-05tests: 'run-basic-test' can enter a root password....Ludovic Courtès 2019-06-24tests: Import (guix build utils) in the marionette....Ludovic Courtès 2019-05-15tests: Skip unreliable "herd invalidate nscd" test....Ludovic Courtès 2019-05-15tests: 'getlogin' test creates its file atomically....Ludovic Courtès 2019-05-09services: Log-in services now require "pam_loginuid"....Ludovic Courtès 2019-03-08activation: Shared system home directories are now 555 and root-owned....Ludovic Courtès 2019-03-04tests: Use non-deprecated (guix store) API....Ludovic Courtès 2019-01-16services: avahi: Deprecate the 'avahi-service' procedure....Ludovic Courtès 2019-01-11services: Deprecate a few more service procedures....Ludovic Courtès 2018-12-18file-systems: Spawn a REPL only when interaction is possible....Ludovic Courtès 2018-11-18activation: Aways pass '-d HOME' to 'useradd'....Ludovic Courtès 2018-11-13services: nscd: Add 'invalidate' and 'statistics' actions....Ludovic Courtès 2018-10-18services: dhcp-client: Deprecate 'dhcp-client-service' procedure....Ludovic Courtès