aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/emacs-xyz.scm16
1 files changed, 8 insertions, 8 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 47f7a1372d..7d83cc7bf2 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -20779,7 +20779,8 @@ hidden.")
"08gygn9fjank5gpi4v6ynrkn0jbknxbwsn7md4p9ndygdbmnkf98"))))
(build-system emacs-build-system)
(inputs
- (list emacs-ansi
+ (list bash-minimal
+ emacs-ansi
emacs-commander
emacs-dash
emacs-f
@@ -20802,8 +20803,8 @@ hidden.")
;; Do not capture the transient source directory in
;; the wrapper.
(delete source-directory
- (string-split (getenv "EMACSLOADPATH") #\:))))
- #t))))
+ (string-split (getenv "EMACSLOADPATH")
+ #\:))))))))
#:include (cons* "^reporters/.*\\.el$" %default-include)))
(home-page "https://github.com/rejeep/ert-runner.el")
(synopsis "Opinionated Ert testing workflow")
@@ -30729,7 +30730,8 @@ asynchronous communications, the RPC response is fairly good.")
(file-name (git-file-name name version))))
(build-system emacs-build-system)
(inputs
- (list perl
+ (list bash-minimal
+ perl
perl-rpc-epc-service
perl-dbi
;; TODO: Adding support for perl-dbd-mysql and others would
@@ -30745,8 +30747,7 @@ asynchronous communications, the RPC response is fairly good.")
(lambda* (#:key inputs #:allow-other-keys)
(let ((perl (assoc-ref inputs "perl")))
(substitute* "edbi.el"
- (("\"perl\"") (string-append "\"" perl "/bin/perl\"")))
- #t)))
+ (("\"perl\"") (string-append "\"" perl "/bin/perl\""))))))
(add-after 'wrap 'wrap-edbi-bridge
(lambda* (#:key inputs outputs #:allow-other-keys)
(let* ((out (assoc-ref outputs "out"))
@@ -30754,8 +30755,7 @@ asynchronous communications, the RPC response is fairly good.")
"/edbi-bridge.pl")))
(chmod bridge #o555)
(wrap-program bridge
- `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB")))))
- #t)))))
+ `("PERL5LIB" ":" prefix (,(getenv "PERL5LIB"))))))))))
(synopsis "Database Interface for Emacs Lisp")
(description "This program connects the database server through Perl's
DBI, and provides DB-accessing API and the simple management UI.")
Update to 2.6.3.1....Tobias Geerinckx-Rice 2018-02-23gnu: skarnet: Use HTTPS for home pages....Tobias Geerinckx-Rice 2017-12-11gnu: skalibs: Fix non-reproducibility issue....Z. Ren