aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/finance.scm5
1 files changed, 2 insertions, 3 deletions
diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3eab2fa14d..a4a9d1b24c 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -171,7 +171,7 @@ line client and a client based on Qt.")
(install-file "test/input/demo.ledger" examples))
#t))
(add-after 'build 'build-doc
- (lambda _ (zero? (system* "make" "doc"))))
+ (lambda _ (invoke "make" "doc")))
(add-before 'check 'check-setup
;; One test fails if it can't set the timezone.
(lambda* (#:key inputs #:allow-other-keys)
@@ -189,8 +189,7 @@ line client and a client based on Qt.")
(dest-dir (string-append guix-dir "/ledger-mode")))
(mkdir-p guix-dir)
(rename-file orig-dir dest-dir)
- (emacs-generate-autoloads ,name dest-dir))
- #t)))))
+ (emacs-generate-autoloads ,name dest-dir)))))))
(inputs
`(("boost" ,boost)
("gmp" ,gmp)
2572>. Reported by Mark H Weaver <mhw@netris.org>. * gnu/system/locale.scm (%not-dot): New variable. (denormalize-codeset, locale-name->definition): New procedures. * gnu/system.scm (locale-name->definition*): New procedure. (operating-system-locale-directory): Instead of raising an error, add the missing locale. * doc/guix.texi (Locales): Adjust accordingly. 2015-10-30system: Add 'locale-libcs' field.Ludovic Courtès * gnu/system/locale.scm (localedef-command)[maybe-version-directory]: New procedure. Use it. (locale-directory): Rename to... (single-locale-directory): ... this. Check the version of LIBC to determine whether to create a "X.Y" sub-directory or to make it a symlink to ".". Add the version number in the derivation name. (locale-directory): New procedure. (%default-locale-libcs): New variable. * gnu/system.scm (<operating-system>)[locale-libcs]: New field. (operating-system-locale-directory): Pass it to 'locale-directory'. * doc/guix.texi (operating-system Reference): Document 'locale-libcs'. (Locales)[Locale Data Compatibility Considerations]: New section. 2015-09-30gnu: libc: Look for locale data under /run/current-system/locale/X.Y.Ludovic Courtès * gnu/packages/base.scm (glibc)[arguments]: Append VERSION to 'libc_cv_localedir'. * gnu/system/locale.scm (localedef-command): Write to the sub-directory called (package-version libc) in #$output. (locale-directory): Create said directory. * doc/guix.texi (Locales): Mention the per-version sub-directory. 2015-08-29doc: Mention the "normalized codeset" used in locale names.Ludovic Courtès * doc/guix.texi (Locales): Introduce "codeset". <%default-locale-definitions>: Mention the "normalized codeset", with an xref to libc's manual. * gnu/system/locale.scm (%default-locale-definitions)[utf8-locale]: Mention the "normalized codeset" in a comment. 2015-01-16system: Add "en_US.UTF-8" to the default locales, for backward compatibility.Ludovic Courtès * gnu/system/locale.scm (%default-locale-definitions): Add "en_US.UTF-8". 2014-11-30system: locale: Fix typo in docstring.Alex Kost * gnu/system/locale.scm (localedef-command): Fix typo. 2014-11-27system: Build system-wide locale definitions.Ludovic Courtès * gnu/system/locale.scm: New file. * gnu-system.am (GNU_SYSTEM_MODULES): Add it. * gnu/system.scm (<operating-system>)[locale]: Change the default to "en_US.utf8". (operating-system-locale-directory): New procecure. (operating-system-derivation): Use it. * doc/guix.texi (Using the Configuration System): Change example locale to "fr_FR.utf8". (operating-system Reference): Add xref to "Locales". Document 'locale-definitions'. (Locales): New section. * po/guix/POTFILES.in: Add gnu/system.scm.