aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/mail.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/mail.scm b/gnu/packages/mail.scm
index 45e189fe07..35626edcc5 100644
--- a/gnu/packages/mail.scm
+++ b/gnu/packages/mail.scm
@@ -1982,7 +1982,7 @@ delivery.")
(("(CONFIGURE_FILE=).*" all var)
(string-append var out "/etc/exim.conf\n"))
(("(EXIM_USER=).*" all var)
- (string-append var "nobody\n"))
+ (string-append var "ref:exim\n"))
(("(FIXED_NEVER_USERS=).*" all var)
(string-append var "\n")) ; no root in build environment
(("(COMPRESS_COMMAND=).*" all var)
@@ -1999,6 +1999,13 @@ delivery.")
(("# (AUTH_PLAINTEXT=yes)" all line) line)
(("# (AUTH_SPA=yes)" all line) line)
(("# (AUTH_TLS=yes)" all line) line))
+ ;; The installation script calls Exim once to get its
+ ;; version number. Exim then fails to find the `exim`
+ ;; user and exits with non-zero status.
+ (substitute* "scripts/exim_install"
+ (("(\\$exim 2>/dev/null)" all var)
+ (string-append
+ "printf 'Exim version " #$version " #1'")))
;; This file has hard-coded relative file names for tools
;; despite the zcat configuration above.
(substitute* "src/exigrep.src"