aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-gtk.scm39
1 files changed, 31 insertions, 8 deletions
diff --git a/gnu/packages/crates-gtk.scm b/gnu/packages/crates-gtk.scm
index 94699475ee..e36737bac6 100644
--- a/gnu/packages/crates-gtk.scm
+++ b/gnu/packages/crates-gtk.scm
@@ -2651,8 +2651,38 @@
#:cargo-development-inputs (("rust-shell-words" ,rust-shell-words-1)
("rust-tempfile" ,rust-tempfile-3))))))
+(define-public rust-gsk4-0.8
+ (package
+ (name "rust-gsk4")
+ (version "0.8.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "gsk4" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1gi1f9s2nd5m2zfwb91vijpzr6nxbfa58inrwml497wkyr5qhqvm"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-cairo-rs" ,rust-cairo-rs-0.19)
+ ("rust-gdk4" ,rust-gdk4-0.8)
+ ("rust-glib" ,rust-glib-0.19)
+ ("rust-graphene-rs" ,rust-graphene-rs-0.19)
+ ("rust-gsk4-sys" ,rust-gsk4-sys-0.8)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pango" ,rust-pango-0.19))
+ #:cargo-development-inputs
+ (("rust-gir-format-check" ,rust-gir-format-check-0.1))))
+ (native-inputs (list pkg-config))
+ (inputs (list gtk))
+ (home-page "https://gtk-rs.org/")
+ (synopsis "Rust bindings of the GSK 4 library")
+ (description "Rust bindings of the GSK 4 library.")
+ (license license:expat)))
+
(define-public rust-gsk4-0.7
(package
+ (inherit rust-gsk4-0.8)
(name "rust-gsk4")
(version "0.7.3")
(source
@@ -2662,7 +2692,6 @@
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32 "0zhzs2dkgiinhgc11akpn2harq3x5n1iq21dnc4h689g3lsqx58d"))))
- (build-system cargo-build-system)
(arguments
`(#:tests? #f ; `Errors` doesn't implement `std::fmt::Display`
#:cargo-inputs (("rust-cairo-rs" ,rust-cairo-rs-0.18)
@@ -2673,13 +2702,7 @@
("rust-libc" ,rust-libc-0.2)
("rust-pango" ,rust-pango-0.18))
#:cargo-development-inputs
- (("rust-gir-format-check" ,rust-gir-format-check-0.1))))
- (native-inputs (list pkg-config))
- (inputs (list gtk))
- (home-page "https://gtk-rs.org/")
- (synopsis "Rust bindings of the GSK 4 library")
- (description "Rust bindings of the GSK 4 library.")
- (license license:expat)))
+ (("rust-gir-format-check" ,rust-gir-format-check-0.1))))))
(define-public rust-gsk4-sys-0.8
(package