aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm27
1 files changed, 22 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ff98763aec..f8c52edd4b 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -47152,21 +47152,22 @@ contents.")
(base32
"02942l2gc7w5r4js7i9063x99szic5mzzk1055j83v4diqpbpxck"))))))
-(define-public rust-open-3
+(define-public rust-open-4
(package
(name "rust-open")
- (version "3.2.0")
+ (version "4.2.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "open" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1y3nhpgh444ns5vqy87jbcnlryqmw62akyi85k2a0m3akq1w0y10"))))
+ (base32 "04kw6xmsjm0wdqidjndhpzl79iksyrhwyik32z28wjjygq63q21s"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-inputs (("rust-pathdiff" ,rust-pathdiff-0.2)
- ("rust-windows-sys" ,rust-windows-sys-0.42))))
+ `(#:cargo-inputs (("rust-is-wsl" ,rust-is-wsl-0.4)
+ ("rust-libc" ,rust-libc-0.2)
+ ("rust-pathdiff" ,rust-pathdiff-0.2))))
(home-page "https://github.com/Byron/open-rs")
(synopsis "Open a path or URL using the program configured on the system")
(description
@@ -47174,6 +47175,22 @@ contents.")
the system.")
(license license:expat)))
+(define-public rust-open-3
+ (package
+ (inherit rust-open-4)
+ (name "rust-open")
+ (version "3.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "open" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "1y3nhpgh444ns5vqy87jbcnlryqmw62akyi85k2a0m3akq1w0y10"))))
+ (arguments
+ `(#:cargo-inputs (("rust-pathdiff" ,rust-pathdiff-0.2)
+ ("rust-windows-sys" ,rust-windows-sys-0.42))))))
+
(define-public rust-open-2
(package
(inherit rust-open-3)