aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/bootloaders.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/bootloaders.scm b/gnu/packages/bootloaders.scm
index 57705cf596..89f051f337 100644
--- a/gnu/packages/bootloaders.scm
+++ b/gnu/packages/bootloaders.scm
@@ -537,12 +537,13 @@ The SUBDIR argument defaults to \"efi/Guix\", as it is also the case for
(lambda _
(invoke "chmod" "a+w" "utils/isohybrid.in")))
(replace 'check
- (lambda _
- (setenv "CC" "gcc")
- (substitute* "tests/unittest/include/unittest/unittest.h"
- ;; Don't look up headers under /usr.
- (("/usr/include/") ""))
- (invoke "make" "unittest"))))))
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (setenv "CC" "gcc")
+ (substitute* "tests/unittest/include/unittest/unittest.h"
+ ;; Don't look up headers under /usr.
+ (("/usr/include/") ""))
+ (invoke "make" "unittest")))))))
(home-page "https://www.syslinux.org")
(synopsis "Lightweight Linux bootloader")
(description "Syslinux is a lightweight Linux bootloader.")