aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cmake.scm4
-rw-r--r--guix/build/cmake-build-system.scm4
2 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/cmake.scm b/gnu/packages/cmake.scm
index c3ed4ae81f..1fb9241596 100644
--- a/gnu/packages/cmake.scm
+++ b/gnu/packages/cmake.scm
@@ -101,6 +101,10 @@
("expat" ,expat)
("bzip2" ,bzip2)
("libarchive" ,libarchive)))
+ (native-search-paths
+ (list (search-path-specification
+ (variable "CMAKE_PREFIX_PATH")
+ (files '("")))))
(home-page "http://www.cmake.org/")
(synopsis "Cross-platform build system")
(description
diff --git a/guix/build/cmake-build-system.scm b/guix/build/cmake-build-system.scm
index 08ae73ef8d..d8d437c653 100644
--- a/guix/build/cmake-build-system.scm
+++ b/guix/build/cmake-build-system.scm
@@ -1,7 +1,7 @@
;;; GNU Guix --- Functional package management for GNU
;;; Copyright © 2013, 2014, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
-;;; Copyright © 2014 Andreas Enge <andreas@enge.fr>
+;;; Copyright © 2014, 2015 Andreas Enge <andreas@enge.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -60,8 +60,6 @@
;; enable verbose output from builds
"-DCMAKE_VERBOSE_MAKEFILE=ON"
,@configure-flags)))
- (setenv "CMAKE_LIBRARY_PATH" (getenv "LIBRARY_PATH"))
- (setenv "CMAKE_INCLUDE_PATH" (getenv "CPATH"))
(format #t "running 'cmake' with arguments ~s~%" args)
(zero? (apply system* "cmake" args)))))