aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/geo.scm25
1 files changed, 14 insertions, 11 deletions
diff --git a/gnu/packages/geo.scm b/gnu/packages/geo.scm
index 6ad3c87ff1..65344bcac2 100644
--- a/gnu/packages/geo.scm
+++ b/gnu/packages/geo.scm
@@ -2786,17 +2786,20 @@ growing set of geoscientific methods.")
sqlite
(list zstd "lib")))
(native-inputs
- (list bison
- flex
- perl
- perl-yaml-tiny
- pkg-config
- python-mock
- python-nose2
- python-pyqt-builder
- qttools-5
- shellcheck
- xorg-server-for-tests))
+ (append
+ (list bison
+ flex
+ perl
+ perl-yaml-tiny
+ pkg-config
+ python-mock
+ python-nose2
+ python-pyqt-builder
+ qttools-5)
+ (if (supported-package? shellcheck)
+ (list shellcheck)
+ '())
+ (list xorg-server-for-tests)))
(home-page "https://qgis.org")
(synopsis "Geographical information system")
(description "QGIS is an easy to use Geographical Information